aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Inline
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2009-05-16 18:21:28 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2009-05-16 18:21:28 +0000
commit948c2dd13932a4013f14d673aeea6c0f15926b1f (patch)
tree84cb3a6b6ea02fed7a6034a9e65e0e0c9ffc57da /devel/p5-Inline
parent0eeba45ee8283a8ad71250516b27ae3091b8b1b1 (diff)
Notes
Diffstat (limited to 'devel/p5-Inline')
-rw-r--r--devel/p5-Inline/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/devel/p5-Inline/Makefile b/devel/p5-Inline/Makefile
index 9f05e942a5ed..1a74563dbc79 100644
--- a/devel/p5-Inline/Makefile
+++ b/devel/p5-Inline/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Inline
PORTVERSION= 0.44
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,9 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Write Perl subroutines in other programming languages
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Parse-RecDescent>=1.8:${PORTSDIR}/devel/p5-Parse-RecDescent
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -24,4 +24,10 @@ MAN3= Inline-API.3 Inline-FAQ.3 Inline-Support.3 Inline.3 \
Inline::C-Cookbook.3 Inline::C.3 \
Inline::C::ParseRecDescent.3 Inline::C::ParseRegExp.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.09:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
+.include <bsd.port.post.mk>