aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Iterator
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-02-18 21:47:17 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-02-18 21:47:17 +0000
commit3bb02f4273d5d70b1416a8b7f4e73cb4b08194fc (patch)
tree81fbc786703dbfcae54a14f37bdac08e9feacf05 /devel/p5-Iterator
parent347dd042034d2f9fc5ea5c4d9fdfe6d8bf1e4c5b (diff)
Notes
Diffstat (limited to 'devel/p5-Iterator')
-rw-r--r--devel/p5-Iterator/Makefile30
-rw-r--r--devel/p5-Iterator/distinfo3
-rw-r--r--devel/p5-Iterator/pkg-descr19
-rw-r--r--devel/p5-Iterator/pkg-plist3
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/p5-Iterator/Makefile b/devel/p5-Iterator/Makefile
new file mode 100644
index 000000000000..6b6ac40fccfe
--- /dev/null
+++ b/devel/p5-Iterator/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Iterator
+# Date created: 18 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Iterator
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/R/RO/ROODE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= A general-purpose iterator class
+
+BUILD_DEPENDS= ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class
+
+MAN3= Iterator.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Iterator/distinfo b/devel/p5-Iterator/distinfo
new file mode 100644
index 000000000000..b8f52f5f7550
--- /dev/null
+++ b/devel/p5-Iterator/distinfo
@@ -0,0 +1,3 @@
+MD5 (Iterator-0.03.tar.gz) = d59487c209c00a26e203c489dbe69b07
+SHA256 (Iterator-0.03.tar.gz) = 5b88a0434eb04927bd0a65e6f920f3ae6ac39b322e72e1b197018b70b0cef87f
+SIZE (Iterator-0.03.tar.gz) = 22454
diff --git a/devel/p5-Iterator/pkg-descr b/devel/p5-Iterator/pkg-descr
new file mode 100644
index 000000000000..ea4f8ca1687e
--- /dev/null
+++ b/devel/p5-Iterator/pkg-descr
@@ -0,0 +1,19 @@
+This module is meant to be the definitive implementation of iterators, as
+popularized by Mark Jason Dominus's lectures and recent book (Higher Order
+Perl, Morgan Kauffman, 2005).
+
+An "iterator" is an object, represented as a code block that generates the
+"next value" of a sequence, and generally implemented as a closure. When
+you need a value to operate on, you pull it from the iterator. If it
+depends on other iterators, it pulls values from them when it needs to.
+Iterators can be chained together (see Iterator::Util for functions that
+help you do just that), queueing up work to be done but not actually doing
+it until a value is needed at the front end of the chain. At that time,
+one data value is pulled through the chain.
+
+Iterator.pm provides a class that simplifies creation and use of these
+iterator objects. Other Iterator:: modules (see "SEE ALSO") provide many
+general-purpose and special-purpose iterator functions.
+
+WWW: http://search.cpan.org/dist/Iterator
+Author: Eric J. Roode <roode@cpan.org>
diff --git a/devel/p5-Iterator/pkg-plist b/devel/p5-Iterator/pkg-plist
new file mode 100644
index 000000000000..1215b36385e1
--- /dev/null
+++ b/devel/p5-Iterator/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Iterator.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Iterator/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Iterator