aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-JSON-RPC-Common/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-05 22:26:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-05 22:26:35 +0000
commitf944abb47b25ba2773024630560540d8d01adf67 (patch)
tree46a34294a4f40cac12c9a05591db82697363c962 /devel/p5-JSON-RPC-Common/Makefile
parent9504e4949bbd92adead0875a6aa1d67af1fc1a8b (diff)
Notes
Diffstat (limited to 'devel/p5-JSON-RPC-Common/Makefile')
-rw-r--r--devel/p5-JSON-RPC-Common/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/devel/p5-JSON-RPC-Common/Makefile b/devel/p5-JSON-RPC-Common/Makefile
new file mode 100644
index 000000000000..9455625a5133
--- /dev/null
+++ b/devel/p5-JSON-RPC-Common/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: p5-JSON-RPC-Common
+# Date created: 03 July, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= JSON-RPC-Common
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Transport agnostic JSON RPC helper objects
+
+RUN_DEPENDS= p5-Moose>=0.81:${PORTSDIR}/devel/p5-Moose \
+ p5-JSON>=2.11:${PORTSDIR}/converters/p5-JSON \
+ p5-MooseX-Types>=0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok \
+ p5-namespace-clean>=0.08:${PORTSDIR}/devel/p5-namespace-clean
+
+PERL_CONFIGURE= YES
+
+MAN3= JSON::RPC::Common::Marshal::Text.3 \
+ JSON::RPC::Common::Procedure::Call.3 \
+ JSON::RPC::Common::Procedure::Return::Version_1_1.3 \
+ JSON::RPC::Common::Procedure::Return::Error.3 \
+ JSON::RPC::Common::Procedure::Call::Version_1_0.3 \
+ JSON::RPC::Common::Procedure::Return.3 \
+ JSON::RPC::Common.3 \
+ JSON::RPC::Common::Procedure::Return::Version_2_0.3 \
+ JSON::RPC::Common::Procedure::Return::Version_1_0.3 \
+ JSON::RPC::Common::Procedure::Call::Version_1_1.3 \
+ JSON::RPC::Common::Procedure::Return::Version_2_0::Error.3 \
+ JSON::RPC::Common::TypeConstraints.3 \
+ JSON::RPC::Common::Procedure::Return::Version_1_1::Error.3 \
+ JSON::RPC::Common::Procedure::Call::Version_2_0.3 \
+ JSON::RPC::Common::Procedure::Return::Version_1_0::Error.3 \
+ JSON::RPC::Common::Marshal::HTTP.3
+
+.include <bsd.port.mk>