aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-JSON-RPC-Common
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-05 22:26:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-05 22:26:35 +0000
commitf944abb47b25ba2773024630560540d8d01adf67 (patch)
tree46a34294a4f40cac12c9a05591db82697363c962 /devel/p5-JSON-RPC-Common
parent9504e4949bbd92adead0875a6aa1d67af1fc1a8b (diff)
downloadports-f944abb47b25ba2773024630560540d8d01adf67.tar.gz
ports-f944abb47b25ba2773024630560540d8d01adf67.zip
Notes
Diffstat (limited to 'devel/p5-JSON-RPC-Common')
-rw-r--r--devel/p5-JSON-RPC-Common/Makefile43
-rw-r--r--devel/p5-JSON-RPC-Common/distinfo3
-rw-r--r--devel/p5-JSON-RPC-Common/pkg-descr8
-rw-r--r--devel/p5-JSON-RPC-Common/pkg-plist31
4 files changed, 85 insertions, 0 deletions
diff --git a/devel/p5-JSON-RPC-Common/Makefile b/devel/p5-JSON-RPC-Common/Makefile
new file mode 100644
index 000000000000..9455625a5133
--- /dev/null
+++ b/devel/p5-JSON-RPC-Common/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: p5-JSON-RPC-Common
+# Date created: 03 July, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= JSON-RPC-Common
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Transport agnostic JSON RPC helper objects
+
+RUN_DEPENDS= p5-Moose>=0.81:${PORTSDIR}/devel/p5-Moose \
+ p5-JSON>=2.11:${PORTSDIR}/converters/p5-JSON \
+ p5-MooseX-Types>=0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok \
+ p5-namespace-clean>=0.08:${PORTSDIR}/devel/p5-namespace-clean
+
+PERL_CONFIGURE= YES
+
+MAN3= JSON::RPC::Common::Marshal::Text.3 \
+ JSON::RPC::Common::Procedure::Call.3 \
+ JSON::RPC::Common::Procedure::Return::Version_1_1.3 \
+ JSON::RPC::Common::Procedure::Return::Error.3 \
+ JSON::RPC::Common::Procedure::Call::Version_1_0.3 \
+ JSON::RPC::Common::Procedure::Return.3 \
+ JSON::RPC::Common.3 \
+ JSON::RPC::Common::Procedure::Return::Version_2_0.3 \
+ JSON::RPC::Common::Procedure::Return::Version_1_0.3 \
+ JSON::RPC::Common::Procedure::Call::Version_1_1.3 \
+ JSON::RPC::Common::Procedure::Return::Version_2_0::Error.3 \
+ JSON::RPC::Common::TypeConstraints.3 \
+ JSON::RPC::Common::Procedure::Return::Version_1_1::Error.3 \
+ JSON::RPC::Common::Procedure::Call::Version_2_0.3 \
+ JSON::RPC::Common::Procedure::Return::Version_1_0::Error.3 \
+ JSON::RPC::Common::Marshal::HTTP.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-JSON-RPC-Common/distinfo b/devel/p5-JSON-RPC-Common/distinfo
new file mode 100644
index 000000000000..2f9528774849
--- /dev/null
+++ b/devel/p5-JSON-RPC-Common/distinfo
@@ -0,0 +1,3 @@
+MD5 (JSON-RPC-Common-0.05.tar.gz) = 096a772d5760b22ea2cda668d031ad95
+SHA256 (JSON-RPC-Common-0.05.tar.gz) = 57bde254b1a381bdfb7b14e287e73319d96577af3fc269e588a720109157f5a1
+SIZE (JSON-RPC-Common-0.05.tar.gz) = 18403
diff --git a/devel/p5-JSON-RPC-Common/pkg-descr b/devel/p5-JSON-RPC-Common/pkg-descr
new file mode 100644
index 000000000000..73bc5260f0ec
--- /dev/null
+++ b/devel/p5-JSON-RPC-Common/pkg-descr
@@ -0,0 +1,8 @@
+p5::JSON::RPC-Common is a perl module provides abstractions for
+JSON-RPC 1.0, 1.1 (both variations) and 2.0 (formerly 1.2)
+Procedure Call and Procedure Return objects (formerly known as
+request and result), along with error objects. It also provides
+marshalling objects to convert the model objects into JSON text
+and HTTP requests/responses.
+
+WWW: http://search.cpan.org/dist/JSON-RPC-Common/
diff --git a/devel/p5-JSON-RPC-Common/pkg-plist b/devel/p5-JSON-RPC-Common/pkg-plist
new file mode 100644
index 000000000000..0a5429ef80ba
--- /dev/null
+++ b/devel/p5-JSON-RPC-Common/pkg-plist
@@ -0,0 +1,31 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/RPC/Common/.packlist
+%%SITE_PERL%%/JSON/RPC/Common.pm
+%%SITE_PERL%%/JSON/RPC/Common/Message.pm
+%%SITE_PERL%%/JSON/RPC/Common/TypeConstraints.pm
+%%SITE_PERL%%/JSON/RPC/Common/Marshal/Text.pm
+%%SITE_PERL%%/JSON/RPC/Common/Marshal/HTTP.pm
+%%SITE_PERL%%/JSON/RPC/Common/Procedure/Call.pm
+%%SITE_PERL%%/JSON/RPC/Common/Procedure/Return.pm
+%%SITE_PERL%%/JSON/RPC/Common/Procedure/Return/Version_1_1.pm
+%%SITE_PERL%%/JSON/RPC/Common/Procedure/Return/Error.pm
+%%SITE_PERL%%/JSON/RPC/Common/Procedure/Return/Version_2_0.pm
+%%SITE_PERL%%/JSON/RPC/Common/Procedure/Return/Version_1_0.pm
+%%SITE_PERL%%/JSON/RPC/Common/Procedure/Return/Version_2_0/Error.pm
+%%SITE_PERL%%/JSON/RPC/Common/Procedure/Return/Version_1_1/Error.pm
+%%SITE_PERL%%/JSON/RPC/Common/Procedure/Return/Version_1_0/Error.pm
+%%SITE_PERL%%/JSON/RPC/Common/Procedure/Call/Version_1_0.pm
+%%SITE_PERL%%/JSON/RPC/Common/Procedure/Call/Version_1_1.pm
+%%SITE_PERL%%/JSON/RPC/Common/Procedure/Call/Version_2_0.pm
+@dirrm %%SITE_PERL%%/JSON/RPC/Common/Procedure/Call
+@dirrm %%SITE_PERL%%/JSON/RPC/Common/Procedure/Return/Version_2_0
+@dirrm %%SITE_PERL%%/JSON/RPC/Common/Procedure/Return/Version_1_1
+@dirrm %%SITE_PERL%%/JSON/RPC/Common/Procedure/Return/Version_1_0
+@dirrm %%SITE_PERL%%/JSON/RPC/Common/Procedure/Return
+@dirrm %%SITE_PERL%%/JSON/RPC/Common/Procedure
+@dirrm %%SITE_PERL%%/JSON/RPC/Common/Marshal
+@dirrm %%SITE_PERL%%/JSON/RPC/Common
+@dirrmtry %%SITE_PERL%%/JSON/RPC
+@dirrmtry %%SITE_PERL%%/JSON
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/RPC/Common
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/RPC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON