aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-JSON-RPC
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-03-29 19:07:50 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-03-29 19:07:50 +0000
commit32eda72431a3d09a709fbb81d7144751ee2f43c0 (patch)
treeae5b9cf252d8541a206342f8b339e5937e91d918 /devel/p5-JSON-RPC
parent51c79cf221a885c27a70beafc1f8c73bcd118ff7 (diff)
downloadports-32eda72431a3d09a709fbb81d7144751ee2f43c0.tar.gz
ports-32eda72431a3d09a709fbb81d7144751ee2f43c0.zip
Notes
Diffstat (limited to 'devel/p5-JSON-RPC')
-rw-r--r--devel/p5-JSON-RPC/Makefile27
-rw-r--r--devel/p5-JSON-RPC/distinfo3
-rw-r--r--devel/p5-JSON-RPC/pkg-descr3
-rw-r--r--devel/p5-JSON-RPC/pkg-plist14
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-JSON-RPC/Makefile b/devel/p5-JSON-RPC/Makefile
new file mode 100644
index 000000000000..56c94896fc3f
--- /dev/null
+++ b/devel/p5-JSON-RPC/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-JSON-RPC
+# Date created: 29 Mar 2009
+# Whom: Vadim Vatlin
+#
+# $FreeBSD$
+#
+
+PORTNAME= JSON-RPC
+PORTVERSION= 0.96
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvatlin@masterhost.ru
+COMMENT= Perl implementation of JSON-RPC 1.1 protocol
+
+RUN_DEPENDS= p5-CGI.pm>=2.92:${PORTSDIR}/www/p5-CGI.pm \
+ p5-JSON>=2.0:${PORTSDIR}/converters/p5-JSON \
+ p5-libwww:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= YES
+
+MAN3= JSON::RPC.3 JSON::RPC::Server.3 JSON::RPC::Client.3 \
+ JSON::RPC::Procedure.3 JSON::RPC::Server::CGI.3 JSONRPC.3 \
+ JSON::RPC::Server::Daemon.3 JSON::RPC::Server::Apache2.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-JSON-RPC/distinfo b/devel/p5-JSON-RPC/distinfo
new file mode 100644
index 000000000000..a8d6c5be579e
--- /dev/null
+++ b/devel/p5-JSON-RPC/distinfo
@@ -0,0 +1,3 @@
+MD5 (JSON-RPC-0.96.tar.gz) = 3912464c3cf59b60131fd2b15400192a
+SHA256 (JSON-RPC-0.96.tar.gz) = 043624b5bd8a9eef18fd03082a1d99b45e3c5202786752a32e051590b565ba15
+SIZE (JSON-RPC-0.96.tar.gz) = 14206
diff --git a/devel/p5-JSON-RPC/pkg-descr b/devel/p5-JSON-RPC/pkg-descr
new file mode 100644
index 000000000000..76665b9bd831
--- /dev/null
+++ b/devel/p5-JSON-RPC/pkg-descr
@@ -0,0 +1,3 @@
+JSON::RPC - Perl implementation of JSON-RPC 1.1 protocol.
+
+WWW: http://search.cpan.org/dist/JSON-RPC/
diff --git a/devel/p5-JSON-RPC/pkg-plist b/devel/p5-JSON-RPC/pkg-plist
new file mode 100644
index 000000000000..645cae59d164
--- /dev/null
+++ b/devel/p5-JSON-RPC/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/RPC/.packlist
+%%SITE_PERL%%/JSON/RPC.pm
+%%SITE_PERL%%/JSON/RPC/Client.pm
+%%SITE_PERL%%/JSON/RPC/Server.pm
+%%SITE_PERL%%/JSON/RPC/Procedure.pm
+%%SITE_PERL%%/JSON/RPC/Server/CGI.pm
+%%SITE_PERL%%/JSON/RPC/Server/Daemon.pm
+%%SITE_PERL%%/JSON/RPC/Server/Apache2.pm
+%%SITE_PERL%%/JSONRPC.pm
+@dirrm %%SITE_PERL%%/JSON/RPC/Server
+@dirrm %%SITE_PERL%%/JSON/RPC
+@dirrmtry %%SITE_PERL%%/JSON
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/RPC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON