aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Locale-Maketext-Gettext/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-06-11 08:13:49 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-06-11 08:13:49 +0000
commit02d9e6ded31c9242202641f2f8b9f4b498120232 (patch)
treed61cdc17163ec813ea4270d18d4614bda1675d01 /devel/p5-Locale-Maketext-Gettext/Makefile
parent4be1016388baa61dbe239bdffd7a810849bab153 (diff)
downloadports-02d9e6ded31c9242202641f2f8b9f4b498120232.tar.gz
ports-02d9e6ded31c9242202641f2f8b9f4b498120232.zip
Notes
Diffstat (limited to 'devel/p5-Locale-Maketext-Gettext/Makefile')
-rw-r--r--devel/p5-Locale-Maketext-Gettext/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/p5-Locale-Maketext-Gettext/Makefile b/devel/p5-Locale-Maketext-Gettext/Makefile
new file mode 100644
index 000000000000..95cf0783bb76
--- /dev/null
+++ b/devel/p5-Locale-Maketext-Gettext/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Locale-Maketext-Gettext
+# Date created: April 26 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Locale-Maketext-Gettext
+PORTVERSION= 1.07
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Locale
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Joins gettext and Maketext frameworks
+
+BUILD_DEPENDS= ${SITE_PERL}/Locale/Maketext.pm:${PORTSDIR}/devel/p5-Locale-Maketext
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN1= maketext.1
+MAN3= Locale::Maketext::Gettext.3 \
+ Locale::Maketext::Gettext::Functions.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE="Need at least perl 5.8 to build"
+.endif
+
+.include <bsd.port.post.mk>