aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Log-Dispatch-Config/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-02-26 20:58:20 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-02-26 20:58:20 +0000
commit30fdc826cb440a4d13107df0b0e3d20473bd80d0 (patch)
tree92c5995b8717631c79a26d4097800b9ed874117c /devel/p5-Log-Dispatch-Config/Makefile
parentd5476df2051f80e9844c994748c618b412650f8b (diff)
downloadports-30fdc826cb440a4d13107df0b0e3d20473bd80d0.tar.gz
ports-30fdc826cb440a4d13107df0b0e3d20473bd80d0.zip
Notes
Diffstat (limited to 'devel/p5-Log-Dispatch-Config/Makefile')
-rw-r--r--devel/p5-Log-Dispatch-Config/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/devel/p5-Log-Dispatch-Config/Makefile b/devel/p5-Log-Dispatch-Config/Makefile
new file mode 100644
index 000000000000..d728b3b66e2f
--- /dev/null
+++ b/devel/p5-Log-Dispatch-Config/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: devel/p5-Log-Dispatch-Config
+# Date created: 27 March 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Log-Dispatch-Config
+PORTVERSION= 1.01
+CATEGORIES= devel sysutils perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Log
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A log4j equivalent for Perl
+
+BUILD_DEPENDS= ${PM_DEPENDS}
+RUN_DEPENDS= ${PM_DEPENDS}
+
+PM_DEPENDS= ${SITE_PERL}/Log/Dispatch.pm:${PORTSDIR}/devel/p5-Log-Dispatch
+PM_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+PM_DEPENDS+= ${SITE_PERL}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig
+PM_DEPENDS+= ${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy
+PM_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+PERL_CONFIGURE= yes
+
+#MAN3= Log::Dispatch::Config.3 \
+# Log::Dispatch::Configurator.3 \
+# Log::Dispatch::Configurator::AppConfig.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>