aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Log-Dispatch-Perl
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2004-02-01 18:23:24 +0000
committerErwin Lansing <erwin@FreeBSD.org>2004-02-01 18:23:24 +0000
commit3f939b1560e0192642f57eb63d23d6d5bb914f3c (patch)
tree6bb71b14300f8398e6fa54a6590351d74a42c795 /devel/p5-Log-Dispatch-Perl
parentda6f941364eb6e65bdfeb3a9a9938cf34486a31e (diff)
downloadports-3f939b1560e0192642f57eb63d23d6d5bb914f3c.tar.gz
ports-3f939b1560e0192642f57eb63d23d6d5bb914f3c.zip
Notes
Diffstat (limited to 'devel/p5-Log-Dispatch-Perl')
-rw-r--r--devel/p5-Log-Dispatch-Perl/Makefile32
-rw-r--r--devel/p5-Log-Dispatch-Perl/distinfo1
-rw-r--r--devel/p5-Log-Dispatch-Perl/pkg-descr7
-rw-r--r--devel/p5-Log-Dispatch-Perl/pkg-plist7
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-Log-Dispatch-Perl/Makefile b/devel/p5-Log-Dispatch-Perl/Makefile
new file mode 100644
index 000000000000..19cfc1cbe681
--- /dev/null
+++ b/devel/p5-Log-Dispatch-Perl/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Log-Dispatch-Perl
+# Date created: Sun Feb 1 14:18:26 GMT 2004
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Log-Dispatch-Perl
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Log
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= A Log::Dispatch plug-in using core Perl functions for logging
+
+BUILD_DEPENDS= ${SITE_PERL}/Log/Dispatch.pm:${PORTSDIR}/devel/p5-Log-Dispatch \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Log::Dispatch::Perl.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= "requires perl 5.6.x or later. Install lang/perl5 and try again"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Log-Dispatch-Perl/distinfo b/devel/p5-Log-Dispatch-Perl/distinfo
new file mode 100644
index 000000000000..32d397940dae
--- /dev/null
+++ b/devel/p5-Log-Dispatch-Perl/distinfo
@@ -0,0 +1 @@
+MD5 (Log-Dispatch-Perl-0.03.tar.gz) = e23dcef192fc33f0213e4c72553b76a7
diff --git a/devel/p5-Log-Dispatch-Perl/pkg-descr b/devel/p5-Log-Dispatch-Perl/pkg-descr
new file mode 100644
index 000000000000..e0e63c35855e
--- /dev/null
+++ b/devel/p5-Log-Dispatch-Perl/pkg-descr
@@ -0,0 +1,7 @@
+The "Log::Dispatch::Perl" module offers a logging alternative using
+standard Perl core functions. It allows you to fall back to the
+common Perl alternatives for logging, such as "warn" and "cluck".
+It also adds the possibility for a logging action to halt the current
+environment, such as with "die" and "croak".
+
+WWW: http://search.cpan.org/dist/Log-Dispatch-Perl/
diff --git a/devel/p5-Log-Dispatch-Perl/pkg-plist b/devel/p5-Log-Dispatch-Perl/pkg-plist
new file mode 100644
index 000000000000..01cfa23bcaf0
--- /dev/null
+++ b/devel/p5-Log-Dispatch-Perl/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Log/Dispatch/Perl.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatch/Perl/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatch/Perl
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatch 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Log 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Log/Dispatch 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Log 2>/dev/null || true