aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Lvalue
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2013-07-03 18:22:27 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2013-07-03 18:22:27 +0000
commit580eff7cb1da3c1e865f47391b74c927b4fc3959 (patch)
tree6884fe6449c441fe4d51d2df2be2663f55f21217 /devel/p5-Lvalue
parent0d106080a3f3da5fd711212677aab3834f1379d5 (diff)
downloadports-580eff7cb1da3c1e865f47391b74c927b4fc3959.tar.gz
ports-580eff7cb1da3c1e865f47391b74c927b4fc3959.zip
Notes
Diffstat (limited to 'devel/p5-Lvalue')
-rw-r--r--devel/p5-Lvalue/Makefile22
-rw-r--r--devel/p5-Lvalue/distinfo2
-rw-r--r--devel/p5-Lvalue/pkg-descr7
-rw-r--r--devel/p5-Lvalue/pkg-plist5
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/p5-Lvalue/Makefile b/devel/p5-Lvalue/Makefile
new file mode 100644
index 000000000000..53665d197926
--- /dev/null
+++ b/devel/p5-Lvalue/Makefile
@@ -0,0 +1,22 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Lvalue
+PORTVERSION= 0.21
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:ASG
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Add lvalue getters and setters to existing objects
+
+BUILD_DEPENDS= p5-Carp>=0:${PORTSDIR}/devel/p5-Carp \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Lvalue.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Lvalue/distinfo b/devel/p5-Lvalue/distinfo
new file mode 100644
index 000000000000..a8bcbbd6041d
--- /dev/null
+++ b/devel/p5-Lvalue/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Lvalue-0.21.tar.gz) = 8a72164955560f43b956b8fd7a3e955a42552a80b8ca01e8e3ab288f704fb57e
+SIZE (Lvalue-0.21.tar.gz) = 5619
diff --git a/devel/p5-Lvalue/pkg-descr b/devel/p5-Lvalue/pkg-descr
new file mode 100644
index 000000000000..77633fe8364a
--- /dev/null
+++ b/devel/p5-Lvalue/pkg-descr
@@ -0,0 +1,7 @@
+Lvalue takes an object produced by some other package and wraps it
+with lvalue functionality implemented with the object's original
+getter and setter routines. Lvalue assumes its object uses the
+relatively standard getter / setter idiom where any arguments is a
+setter, and no arguments is a getter.
+
+WWW: http://search.cpan.org/dist/Lvalue/
diff --git a/devel/p5-Lvalue/pkg-plist b/devel/p5-Lvalue/pkg-plist
new file mode 100644
index 000000000000..c9f434d84c55
--- /dev/null
+++ b/devel/p5-Lvalue/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Lvalue.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Lvalue/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Lvalue/Path
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Lvalue