aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Mock-Quick
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-02-17 02:41:29 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-02-17 02:41:29 +0000
commita99a240f4b6209c00ddea022f5c848149539102a (patch)
treec24d8aaef6d30cc877825d3737a271d67e3de520 /devel/p5-Mock-Quick
parent3cfcd74668aac7e13f36d267c00a8eb7b3f085bd (diff)
downloadports-a99a240f4b6209c00ddea022f5c848149539102a.tar.gz
ports-a99a240f4b6209c00ddea022f5c848149539102a.zip
Notes
Diffstat (limited to 'devel/p5-Mock-Quick')
-rw-r--r--devel/p5-Mock-Quick/Makefile29
-rw-r--r--devel/p5-Mock-Quick/distinfo2
-rw-r--r--devel/p5-Mock-Quick/pkg-descr14
-rw-r--r--devel/p5-Mock-Quick/pkg-plist9
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/p5-Mock-Quick/Makefile b/devel/p5-Mock-Quick/Makefile
new file mode 100644
index 000000000000..30dbda0f20f1
--- /dev/null
+++ b/devel/p5-Mock-Quick/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Mock-Quick
+# Date Created: 17 Feb, 2011
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mock-Quick
+PORTVERSION= 1.001
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/E/EX/EXODIST
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Quickly mock objects and classes
+
+RUN_DEPENDS= p5-Exporter-Declare>=0:${PORTSDIR}/devel/p5-Exporter-Declare
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Mock::Quick.3 Object::Quick.3 \
+ Mock::Quick::Class.3 \
+ Mock::Quick::Method.3 \
+ Mock::Quick::Object.3 \
+ Mock::Quick::Util.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Mock-Quick/distinfo b/devel/p5-Mock-Quick/distinfo
new file mode 100644
index 000000000000..ed36ce8ee02c
--- /dev/null
+++ b/devel/p5-Mock-Quick/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Mock-Quick-1.001.tar.gz) = 8831e5a57cf2b54300ca8f41001134c85d83dd44518ea82edddb46c3c1f4a0de
+SIZE (Mock-Quick-1.001.tar.gz) = 10345
diff --git a/devel/p5-Mock-Quick/pkg-descr b/devel/p5-Mock-Quick/pkg-descr
new file mode 100644
index 000000000000..0355198f1098
--- /dev/null
+++ b/devel/p5-Mock-Quick/pkg-descr
@@ -0,0 +1,14 @@
+Mock-Object provides a declarative mocking interface that results in a
+very concise, but clear syntax. There are seperate facilities for
+mocking object instances, and classes. You can quickly create an
+instance of an object with custom attributes and methods. You can also
+quickly create an anonymous class, optionally inhereting from another,
+with whatever methods you desire.
+
+Mock-Object also provides a tool that provides an OO interface to
+overriding methods in existing classes. This tool also allows for the
+restoration of the original class methods. Best of all this is a
+localized tool, when your control object falls out of scope the original
+class is restored.
+
+WWW: http://search.cpan.org/dist/Mock-Quick/
diff --git a/devel/p5-Mock-Quick/pkg-plist b/devel/p5-Mock-Quick/pkg-plist
new file mode 100644
index 000000000000..d6162fc6ad94
--- /dev/null
+++ b/devel/p5-Mock-Quick/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Mock/Quick.pm
+%%SITE_PERL%%/Mock/Quick/Class.pm
+%%SITE_PERL%%/Mock/Quick/Method.pm
+%%SITE_PERL%%/Mock/Quick/Object.pm
+%%SITE_PERL%%/Mock/Quick/Util.pm
+%%SITE_PERL%%/Object/Quick.pm
+@dirrmtry %%SITE_PERL%%/Object
+@dirrm %%SITE_PERL%%/Mock/Quick
+@dirrmtry %%SITE_PERL%%/Mock