aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Module-Build-Convert
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-04-27 01:14:28 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-04-27 01:14:28 +0000
commit472088c146b645590a8f873a349f5c786d99a3af (patch)
tree4189e37f3b3811707fd7bc4fcf3be9370f6fdc8f /devel/p5-Module-Build-Convert
parent8ae46387157c8bb989cb44050a16b9eb507a3857 (diff)
downloadports-472088c146b645590a8f873a349f5c786d99a3af.tar.gz
ports-472088c146b645590a8f873a349f5c786d99a3af.zip
Notes
Diffstat (limited to 'devel/p5-Module-Build-Convert')
-rw-r--r--devel/p5-Module-Build-Convert/Makefile32
-rw-r--r--devel/p5-Module-Build-Convert/distinfo3
-rw-r--r--devel/p5-Module-Build-Convert/pkg-descr11
-rw-r--r--devel/p5-Module-Build-Convert/pkg-plist4
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/p5-Module-Build-Convert/Makefile b/devel/p5-Module-Build-Convert/Makefile
new file mode 100644
index 000000000000..acdc3604ad53
--- /dev/null
+++ b/devel/p5-Module-Build-Convert/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Module::Build::Convert
+# Date created: Apr 27 2006
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= Module-Build-Convert
+PORTVERSION= 0.28
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Module
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Makefile.PL to Build.PL converter
+
+BUILD_DEPENDS= Test-More:${PORTSDIR}/devel/p5-Test-Simple \
+ Test-Pod:${PORTSDIR}/devel/p5-Test-Pod \
+ Test-Pod-Coverage:${PORTSDIR}/devel/p5-Test-Pod-Coverage
+RUN_DEPENDS= Data-Dumper:${PORTSDIR}/devel/p5-Data-Dumper \
+ ExtUtils-MakeMaker:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker \
+ File-Spec:${PORTSDIR}/devel/p5-PathTools \
+ File-Slurp:${PORTSDIR}/devel/p5-File-Slurp \
+ File-HomeDir:${PORTSDIR}/devel/p5-File-HomeDir
+
+PERL_MODBUILD= yes
+
+MAN3= Module::Build::Convert.3
+MAN1= make2build.1
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Module-Build-Convert/distinfo b/devel/p5-Module-Build-Convert/distinfo
new file mode 100644
index 000000000000..21f69d75d6b5
--- /dev/null
+++ b/devel/p5-Module-Build-Convert/distinfo
@@ -0,0 +1,3 @@
+MD5 (Module-Build-Convert-0.28.tar.gz) = 855adbe029cefd7f87d34772651dc767
+SHA256 (Module-Build-Convert-0.28.tar.gz) = ad920da24fea2748465d14590c46e53ea4f03be5385d1248709689124a03762f
+SIZE (Module-Build-Convert-0.28.tar.gz) = 14836
diff --git a/devel/p5-Module-Build-Convert/pkg-descr b/devel/p5-Module-Build-Convert/pkg-descr
new file mode 100644
index 000000000000..e883a9d075b3
--- /dev/null
+++ b/devel/p5-Module-Build-Convert/pkg-descr
@@ -0,0 +1,11 @@
+Module::Build::Convert - Makefile.PL to Build.PL converter
+
+ExtUtils::MakeMaker has been a de-facto standard for the common
+distribution of Perl modules; Module::Build is expected to supersede
+ExtUtils::MakeMaker in some time (part of the Perl core as of 5.10?)
+
+The transition takes place slowly, as the converting process manually
+achieved is yet an uncommon practice. The Module::Build::Convert
+Makefile.PL parser is intended to ease the transition process.
+
+WWW: http://search.cpan.org/dist/Module-Build-Convert/
diff --git a/devel/p5-Module-Build-Convert/pkg-plist b/devel/p5-Module-Build-Convert/pkg-plist
new file mode 100644
index 000000000000..09a87f6c857a
--- /dev/null
+++ b/devel/p5-Module-Build-Convert/pkg-plist
@@ -0,0 +1,4 @@
+bin/make2build
+%%SITE_PERL%%/Module/Build/Convert.pm
+@dirrmtry %%SITE_PERL%%/Module/Build
+@dirrmtry %%SITE_PERL%%/Module