aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Module-Build-Kwalitee/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-04-29 08:34:11 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-04-29 08:34:11 +0000
commite40f6c970f84c65aaf9f2e22b73496eb7573cc6b (patch)
tree0f4a192908c18cecf33949a076ebc114d53fcd1a /devel/p5-Module-Build-Kwalitee/Makefile
parent682b9b4b8f5774698c19ff666f5f73854f84a7e1 (diff)
downloadports-e40f6c970f84c65aaf9f2e22b73496eb7573cc6b.tar.gz
ports-e40f6c970f84c65aaf9f2e22b73496eb7573cc6b.zip
Notes
Diffstat (limited to 'devel/p5-Module-Build-Kwalitee/Makefile')
-rw-r--r--devel/p5-Module-Build-Kwalitee/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/p5-Module-Build-Kwalitee/Makefile b/devel/p5-Module-Build-Kwalitee/Makefile
new file mode 100644
index 000000000000..5f07fc75cb56
--- /dev/null
+++ b/devel/p5-Module-Build-Kwalitee/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: Module::Build::Kwalitee
+# Date created: 2006-04-27
+# Whom: Yuan-Chung Hsiao & <ychsiao@ychsiao.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Module-Build-Kwalitee
+PORTVERSION= 0.20
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/S/ST/STIG
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ychsiao@ychsiao.org
+COMMENT= Module::Build subclass with prepackaged tests
+
+BUILD_DEPENDS= p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML \
+ p5-Module-Build>=0.2609:${PORTSDIR}/devel/p5-Module-Build \
+ p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
+RUN_DEPENDS= p5-File-Fine-Rule>=0:${PORTSDIR}/devel/p5-File-Find-Rule
+
+PERL_MODBUILD= yes
+
+MAN3= Module::Build::Kwalitee.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.1 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>