aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Module-Build/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2003-06-29 09:30:08 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2003-06-29 09:30:08 +0000
commit70720bae3496806a42644e070707bb3911d797a3 (patch)
treec7315b4e1760c7d6e20627c559db2dc978078c8d /devel/p5-Module-Build/Makefile
parent0c691657a74c88147c1a6ace75efdb7632721a61 (diff)
Notes
Diffstat (limited to 'devel/p5-Module-Build/Makefile')
-rw-r--r--devel/p5-Module-Build/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/p5-Module-Build/Makefile b/devel/p5-Module-Build/Makefile
new file mode 100644
index 000000000000..787fb75c205c
--- /dev/null
+++ b/devel/p5-Module-Build/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Module::Build
+# Date created: 29 June 2003
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Module-Build
+PORTVERSION= 0.18
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Module
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Build and install Perl modules
+
+BUILD_DEPENDS= ${SITE_PERL}/Module/Info.pm:${PORTSDIR}/devel/p5-Module-Info \
+ ${SITE_PERL}/ExtUtils/ParseXS.pm:${PORTSDIR}/devel/p5-ExtUtils-ParseXS \
+ ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>