aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Module-Compile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-06-01 01:14:22 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-06-01 01:14:22 +0000
commite0e4e45994036cf1998574e16cd74923646c5b96 (patch)
treee834d85d87c49b364294cb3f6c2141cac3cef6ee /devel/p5-Module-Compile
parenta2be9a207edce546655f72e7d49d055607a4a8a8 (diff)
downloadports-e0e4e45994036cf1998574e16cd74923646c5b96.tar.gz
ports-e0e4e45994036cf1998574e16cd74923646c5b96.zip
Notes
Diffstat (limited to 'devel/p5-Module-Compile')
-rw-r--r--devel/p5-Module-Compile/Makefile30
-rw-r--r--devel/p5-Module-Compile/distinfo3
-rw-r--r--devel/p5-Module-Compile/pkg-descr13
-rw-r--r--devel/p5-Module-Compile/pkg-plist9
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/p5-Module-Compile/Makefile b/devel/p5-Module-Compile/Makefile
new file mode 100644
index 000000000000..09eb6d32e4e3
--- /dev/null
+++ b/devel/p5-Module-Compile/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Module-Compile
+# Date created: 2006-05-30
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Module-Compile
+PORTVERSION= 0.15
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Module
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= Provide a system for writing modules that compile other Perl modules
+
+PERL_CONFIGURE= yes
+
+MAN3= Module::Compile.3 \
+ Module::Install::Admin::PMC.3 \
+ Module::Install::PMC.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Module-Compile/distinfo b/devel/p5-Module-Compile/distinfo
new file mode 100644
index 000000000000..2c2d7bed2e87
--- /dev/null
+++ b/devel/p5-Module-Compile/distinfo
@@ -0,0 +1,3 @@
+MD5 (Module-Compile-0.15.tar.gz) = dbe9327c2ec73fa37264e035da8f836b
+SHA256 (Module-Compile-0.15.tar.gz) = e4ebaf1d8bd9051121cdbcf08de6d35259d7cec440548538cf0df4b18ac7e84a
+SIZE (Module-Compile-0.15.tar.gz) = 42449
diff --git a/devel/p5-Module-Compile/pkg-descr b/devel/p5-Module-Compile/pkg-descr
new file mode 100644
index 000000000000..6f3ef96116cd
--- /dev/null
+++ b/devel/p5-Module-Compile/pkg-descr
@@ -0,0 +1,13 @@
+This module provides a system for writing modules that *compile* other
+Perl modules.
+
+Modules that use these compilation modules get compiled into some
+altered form the first time they are run. The result is cached into
+".pmc" files.
+
+Perl has native support for ".pmc" files. It always checks for them,
+before loading a ".pm" file.
+
+
+Author: Ingy <ingy@cpan.org>
+WWW: http://search.cpan.org/~ingy/Module-Compile-0.15/
diff --git a/devel/p5-Module-Compile/pkg-plist b/devel/p5-Module-Compile/pkg-plist
new file mode 100644
index 000000000000..7f558fb1b437
--- /dev/null
+++ b/devel/p5-Module-Compile/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Module/Compile.pm
+%%SITE_PERL%%/Module/Install/Admin/PMC.pm
+%%SITE_PERL%%/Module/Install/PMC.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Module/Compile/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Module/Compile
+@dirrm %%SITE_PERL%%/Module/Install/Admin
+@dirrm %%SITE_PERL%%/Module/Install
+@dirrmtry %%SITE_PERL%%/Module