aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Module-CoreList
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2009-01-15 15:34:33 +0000
committerLars Thegler <lth@FreeBSD.org>2009-01-15 15:34:33 +0000
commitd7c685540801569507003a4c682a8d672ab7b38b (patch)
tree6a1c19513013b443f9e5e86337d6b78de63d7487 /devel/p5-Module-CoreList
parent2e2b07a6ba9c57e943a78ec423ac346a93731f0c (diff)
- Better avoidance of collision with perl-5.8.9's bin/corelist
- Reinstall perl-5.8.9's bin/corelist if removed by a previous deinstallation of this port - Remove patch droppings Reviewed by: tobez
Notes
Notes: svn path=/head/; revision=226172
Diffstat (limited to 'devel/p5-Module-CoreList')
-rw-r--r--devel/p5-Module-CoreList/Makefile26
-rw-r--r--devel/p5-Module-CoreList/files/pkg-install.in9
-rw-r--r--devel/p5-Module-CoreList/pkg-plist2
3 files changed, 27 insertions, 10 deletions
diff --git a/devel/p5-Module-CoreList/Makefile b/devel/p5-Module-CoreList/Makefile
index 8c14ca3d105b..d83cd480b036 100644
--- a/devel/p5-Module-CoreList/Makefile
+++ b/devel/p5-Module-CoreList/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Module-CoreList
PORTVERSION= 2.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -17,18 +17,26 @@ COMMENT= See what modules shipped with versions of perl
PERL_CONFIGURE= yes
-MAN1= corelist.1
+MAN1= p5corelist.1
MAN3= Module::CoreList.3
+SUB_FILES= pkg-install
+
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} >= 5.00809
-.undef MAN1
-PLIST_SUB+= PL_FILES="@comment "
-pre-patch:
- @${PERL} -pi -e "s,'corelist',," ${WRKSRC}/Makefile.PL
-.else
-PLIST_SUB+= PL_FILES=""
+.if ${PERL_LEVEL} < 500809
+PLIST_FILES+= bin/corelist
.endif
+pre-patch:
+ @${MV} ${WRKSRC}/corelist ${WRKSRC}/p5corelist
+ @${PERL} -pi -e 's,^corelist$$,p5corelist,' ${WRKSRC}/MANIFEST
+ @${PERL} -pi -e 's,corelist,p5corelist,' ${WRKSRC}/Makefile.PL ${WRKSRC}/t/pod.t
+
+post-patch:
+ @${RM} ${WRKSRC}/lib/Module/CoreList.pm.orig
+
+post-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
.include <bsd.port.post.mk>
diff --git a/devel/p5-Module-CoreList/files/pkg-install.in b/devel/p5-Module-CoreList/files/pkg-install.in
new file mode 100644
index 000000000000..6c300ed94f2a
--- /dev/null
+++ b/devel/p5-Module-CoreList/files/pkg-install.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+case $2 in
+POST-INSTALL)
+ if ! test -f %%PREFIX%%/bin/corelist; then
+ echo "===> Reinstalling missing %%PREFIX%%/bin/corelist"
+ cp -p %%PREFIX%%/bin/p5corelist %%PREFIX%%/bin/corelist
+ fi
+esac
diff --git a/devel/p5-Module-CoreList/pkg-plist b/devel/p5-Module-CoreList/pkg-plist
index b45e1f9d2653..306bff08b1fd 100644
--- a/devel/p5-Module-CoreList/pkg-plist
+++ b/devel/p5-Module-CoreList/pkg-plist
@@ -1,4 +1,4 @@
-%%PL_FILES%%bin/corelist
+bin/p5corelist
%%SITE_PERL%%/Module/CoreList.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Module/CoreList/.packlist
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Module/CoreList