aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Module-Manifest
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-15 17:13:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-15 17:13:27 +0000
commit2c31fcf4a25df2f06df31810b0c93d54d00ad786 (patch)
tree076c8032475284f8636b9ffdbc9140c432c0b625 /devel/p5-Module-Manifest
parent8dcdff4db8b4d8e5b4b3c2bc54f33af4a6d07166 (diff)
downloadports-2c31fcf4a25df2f06df31810b0c93d54d00ad786.tar.gz
ports-2c31fcf4a25df2f06df31810b0c93d54d00ad786.zip
Notes
Diffstat (limited to 'devel/p5-Module-Manifest')
-rw-r--r--devel/p5-Module-Manifest/Makefile24
-rw-r--r--devel/p5-Module-Manifest/distinfo3
-rw-r--r--devel/p5-Module-Manifest/pkg-descr10
-rw-r--r--devel/p5-Module-Manifest/pkg-plist6
4 files changed, 43 insertions, 0 deletions
diff --git a/devel/p5-Module-Manifest/Makefile b/devel/p5-Module-Manifest/Makefile
new file mode 100644
index 000000000000..5ec1cbd4637c
--- /dev/null
+++ b/devel/p5-Module-Manifest/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Module-Manifest
+# Date created: March 8th 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Module-Manifest
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= Parse and examine a Perl distribution MANIFEST file
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Module::Manifest.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Module-Manifest/distinfo b/devel/p5-Module-Manifest/distinfo
new file mode 100644
index 000000000000..9fb71b9fc16b
--- /dev/null
+++ b/devel/p5-Module-Manifest/distinfo
@@ -0,0 +1,3 @@
+MD5 (Module-Manifest-0.04.tar.gz) = 7d41517f9ee7dd376a44c66d7e23b386
+SHA256 (Module-Manifest-0.04.tar.gz) = b18db97a29b417486930cac1bda8f785415223b0b78cde433ee23e48daa3e92f
+SIZE (Module-Manifest-0.04.tar.gz) = 22722
diff --git a/devel/p5-Module-Manifest/pkg-descr b/devel/p5-Module-Manifest/pkg-descr
new file mode 100644
index 000000000000..9ae551b5bd89
--- /dev/null
+++ b/devel/p5-Module-Manifest/pkg-descr
@@ -0,0 +1,10 @@
+Module::Manifest is a simple utility module created originally for use
+in Module::Inspector. It allows you to load the MANIFEST file that comes
+in a Perl distribution tarball, examine the contents, and perform some
+simple tasks.
+
+Granted, the functionality needed to do this is quite simple, but the Perl
+distribution MANIFEST specification contains a couple of little idiosyncracies,
+such as line comments and space-seperated inline comments.
+
+WWW: http://search.cpan.org/dist/Module-Manifest/
diff --git a/devel/p5-Module-Manifest/pkg-plist b/devel/p5-Module-Manifest/pkg-plist
new file mode 100644
index 000000000000..ac466fc274c5
--- /dev/null
+++ b/devel/p5-Module-Manifest/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Module/Manifest.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Module/Manifest/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Module/Manifest
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Module
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/Module