aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Module-Pluggable-Fast
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2005-04-07 09:20:51 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2005-04-07 09:20:51 +0000
commitdb1a4b3c71475e2c6e80bb21c52473c8b36dcc4e (patch)
tree365d4835062afc31bd29d6bc8e9629840d295585 /devel/p5-Module-Pluggable-Fast
parente6ed1295a79545e9e45e282d10b6aa559f22d1b2 (diff)
downloadports-db1a4b3c71475e2c6e80bb21c52473c8b36dcc4e.tar.gz
ports-db1a4b3c71475e2c6e80bb21c52473c8b36dcc4e.zip
Notes
Diffstat (limited to 'devel/p5-Module-Pluggable-Fast')
-rw-r--r--devel/p5-Module-Pluggable-Fast/Makefile27
-rw-r--r--devel/p5-Module-Pluggable-Fast/distinfo2
-rw-r--r--devel/p5-Module-Pluggable-Fast/pkg-descr4
-rw-r--r--devel/p5-Module-Pluggable-Fast/pkg-plist6
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/p5-Module-Pluggable-Fast/Makefile b/devel/p5-Module-Pluggable-Fast/Makefile
new file mode 100644
index 000000000000..fb0cabb84575
--- /dev/null
+++ b/devel/p5-Module-Pluggable-Fast/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: p5-Module-Pluggable-Fast
+# Date created: Apr 7, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Module-Pluggable-Fast
+PORTVERSION= 0.13
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Module
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Fast plugins with instantiation
+
+BUILD_DEPENDS= ${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule \
+ ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-exports
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Module::Pluggable::Fast.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Module-Pluggable-Fast/distinfo b/devel/p5-Module-Pluggable-Fast/distinfo
new file mode 100644
index 000000000000..0e7a251857d4
--- /dev/null
+++ b/devel/p5-Module-Pluggable-Fast/distinfo
@@ -0,0 +1,2 @@
+MD5 (Module-Pluggable-Fast-0.13.tar.gz) = b9b26ac77e8800a7e03991427d2eb557
+SIZE (Module-Pluggable-Fast-0.13.tar.gz) = 2327
diff --git a/devel/p5-Module-Pluggable-Fast/pkg-descr b/devel/p5-Module-Pluggable-Fast/pkg-descr
new file mode 100644
index 000000000000..7fe4b2f052e9
--- /dev/null
+++ b/devel/p5-Module-Pluggable-Fast/pkg-descr
@@ -0,0 +1,4 @@
+Similar to Module::Pluggable but instantiates plugins as soon as they're
+found, useful for code generators like Class::DBI::Loader.
+
+WWW: http://search.cpan.org/dist/Module-Pluggable-Fast/
diff --git a/devel/p5-Module-Pluggable-Fast/pkg-plist b/devel/p5-Module-Pluggable-Fast/pkg-plist
new file mode 100644
index 000000000000..5a65e395713a
--- /dev/null
+++ b/devel/p5-Module-Pluggable-Fast/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Module/Pluggable/Fast.pm
+@unexec rmdir %D/%%SITE_PERL%%/Module/Pluggable 2>/dev/null || true
+%%SITE_PERL%%/%%PERL_ARCH%%//auto/Module/Pluggable/Fast/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%//auto/Module/Pluggable/Fast
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%//auto/Module/Pluggable 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%//auto/Module 2>/dev/null || true