aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Moose-Autobox/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-28 17:13:03 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-28 17:13:03 +0000
commitf89378ad55875080ae057699849099f2181fead3 (patch)
tree868bb2ba8d55b7917f84904392a1d1aa60f0d894 /devel/p5-Moose-Autobox/Makefile
parente42ce61cd272340b486ab5e7200bf3d679fb1463 (diff)
downloadports-f89378ad55875080ae057699849099f2181fead3.tar.gz
ports-f89378ad55875080ae057699849099f2181fead3.zip
Notes
Diffstat (limited to 'devel/p5-Moose-Autobox/Makefile')
-rw-r--r--devel/p5-Moose-Autobox/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-Moose-Autobox/Makefile b/devel/p5-Moose-Autobox/Makefile
new file mode 100644
index 000000000000..21242a9e06c9
--- /dev/null
+++ b/devel/p5-Moose-Autobox/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: devel/p5-Moose-Autobox
+# Date created: 25 July 2009
+# Whom: Bill Brinzer <bill.brinzer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Moose-Autobox
+PORTVERSION= 0.09
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/R/RJ/RJBS/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bill.brinzer@gmail.com
+COMMENT= Autoboxed wrappers for Native Perl datatypes
+
+BUILD_DEPENDS= p5-autobox>=2.23:${PORTSDIR}/devel/p5-autobox \
+ p5-Moose>=0.42:${PORTSDIR}/devel/p5-Moose \
+ p5-Perl6-Junction>=1.40000:${PORTSDIR}/devel/p5-Perl6-Junction \
+ p5-Test-Exception>=0.21:${PORTSDIR}/devel/p5-Test-Exception
+RUN_DEPENDS= p5-autobox>=2.23:${PORTSDIR}/devel/p5-autobox \
+ p5-Moose>=0.42:${PORTSDIR}/devel/p5-Moose \
+ p5-Perl6-Junction>=1.40000:${PORTSDIR}/devel/p5-Perl6-Junction \
+ p5-Test-Exception>=0.21:${PORTSDIR}/devel/p5-Test-Exception
+
+PERL_CONFIGURE= 5.6.0+
+
+MAN3= Moose::Autobox.3 \
+ Moose::Autobox::Array.3 \
+ Moose::Autobox::Code.3 \
+ Moose::Autobox::Defined.3 \
+ Moose::Autobox::Hash.3 \
+ Moose::Autobox::Indexed.3 \
+ Moose::Autobox::Item.3 \
+ Moose::Autobox::List.3 \
+ Moose::Autobox::Number.3 \
+ Moose::Autobox::Ref.3 \
+ Moose::Autobox::Scalar.3 \
+ Moose::Autobox::String.3 \
+ Moose::Autobox::Undef.3 \
+ Moose::Autobox::Value.3
+
+.include <bsd.port.mk>