aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-MooseX-CompileTime-Traits
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-10-10 00:36:34 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-10-10 00:36:34 +0000
commit613c106d73d9b0859c444dd6a4940dedb6ff1bd7 (patch)
tree80638ba06fa54f831e276894a9f6d1b170a97b92 /devel/p5-MooseX-CompileTime-Traits
parent388de7d7496906037f137e52baa1a10c3934bc0d (diff)
downloadports-613c106d73d9b0859c444dd6a4940dedb6ff1bd7.tar.gz
ports-613c106d73d9b0859c444dd6a4940dedb6ff1bd7.zip
Notes
Diffstat (limited to 'devel/p5-MooseX-CompileTime-Traits')
-rw-r--r--devel/p5-MooseX-CompileTime-Traits/Makefile26
-rw-r--r--devel/p5-MooseX-CompileTime-Traits/distinfo3
-rw-r--r--devel/p5-MooseX-CompileTime-Traits/pkg-descr10
-rw-r--r--devel/p5-MooseX-CompileTime-Traits/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-MooseX-CompileTime-Traits/Makefile b/devel/p5-MooseX-CompileTime-Traits/Makefile
new file mode 100644
index 000000000000..4756fe968013
--- /dev/null
+++ b/devel/p5-MooseX-CompileTime-Traits/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: MooseX::CompileTime::Traits
+# Date created: 10 Oct 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MooseX-CompileTime-Traits
+PORTVERSION= 1.102570
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to allow compile time traits for classes/roles
+
+RUN_DEPENDS= \
+ p5-Moose>0:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Declare>0:${PORTSDIR}/devel/p5-MooseX-Declare
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= MooseX::CompileTime::Traits.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-CompileTime-Traits/distinfo b/devel/p5-MooseX-CompileTime-Traits/distinfo
new file mode 100644
index 000000000000..1a357798aaa6
--- /dev/null
+++ b/devel/p5-MooseX-CompileTime-Traits/distinfo
@@ -0,0 +1,3 @@
+MD5 (MooseX-CompileTime-Traits-1.102570.tar.gz) = aa5a0776d81ccdbe8910257b57121e12
+SHA256 (MooseX-CompileTime-Traits-1.102570.tar.gz) = 9e748c92bba2a1d4f83d02e015c05f0f621a92ce15bbb76a6dccfdff52664d4b
+SIZE (MooseX-CompileTime-Traits-1.102570.tar.gz) = 9931
diff --git a/devel/p5-MooseX-CompileTime-Traits/pkg-descr b/devel/p5-MooseX-CompileTime-Traits/pkg-descr
new file mode 100644
index 000000000000..21e59de4eacf
--- /dev/null
+++ b/devel/p5-MooseX-CompileTime-Traits/pkg-descr
@@ -0,0 +1,10 @@
+MooseX::CompileTime::Traits allows role application at compile time
+via use statements. What this class does is provide an import method
+that will apply each of the roles (along with any arguments for
+parameterized roles).
+
+Roles and their arguments should be provided as an ArrayRef of tuples.
+
+Simply 'with' the role to gain the functionality.
+
+WWW: http://search.cpan.org/dist/MooseX-CompileTime-Traits/
diff --git a/devel/p5-MooseX-CompileTime-Traits/pkg-plist b/devel/p5-MooseX-CompileTime-Traits/pkg-plist
new file mode 100644
index 000000000000..ba09ff26205a
--- /dev/null
+++ b/devel/p5-MooseX-CompileTime-Traits/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/CompileTime/Traits/.packlist
+%%SITE_PERL%%/MooseX/CompileTime/Traits.pm
+@dirrmtry %%SITE_PERL%%/MooseX/CompileTime
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/CompileTime/Traits
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/CompileTime