aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-MooseX-Getopt
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2008-07-28 00:53:55 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2008-07-28 00:53:55 +0000
commit34890e8735b87e83a755017fe5cbd077b4bb25cf (patch)
treeac4fb7789e2aff59e195732c7b80a6689a5cda2e /devel/p5-MooseX-Getopt
parent01ecf0f1c2ca9d3cc34ba91992c136a4e3a165b2 (diff)
Notes
Diffstat (limited to 'devel/p5-MooseX-Getopt')
-rw-r--r--devel/p5-MooseX-Getopt/Makefile35
-rw-r--r--devel/p5-MooseX-Getopt/distinfo3
-rw-r--r--devel/p5-MooseX-Getopt/pkg-descr9
-rw-r--r--devel/p5-MooseX-Getopt/pkg-plist15
4 files changed, 62 insertions, 0 deletions
diff --git a/devel/p5-MooseX-Getopt/Makefile b/devel/p5-MooseX-Getopt/Makefile
new file mode 100644
index 000000000000..7d6817682e36
--- /dev/null
+++ b/devel/p5-MooseX-Getopt/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: devel/p5-MooseX-Getopt
+# Date created: 28 Jul 2008
+# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MooseX-Getopt
+PORTVERSION= 0.15
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= A Moose role for processing command line options
+
+RUN_DEPENDS= p5-Moose>=0.43:${PORTSDIR}/devel/p5-Moose \
+ p5-Getopt-Long>=2.37:${PORTSDIR}/devel/p5-Getopt-Long \
+ p5-Getopt-Long-Descriptive>=0:${PORTSDIR}/devel/p5-Getopt-Long-Descriptive
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= MooseX::Getopt.3 \
+ MooseX::Getopt::Meta::Attribute.3 \
+ MooseX::Getopt::Meta::Attribute::NoGetopt.3 \
+ MooseX::Getopt::Meta::Attribute::Trait.3 \
+ MooseX::Getopt::Meta::Attribute::Trait::NoGetopt.3 \
+ MooseX::Getopt::OptionTypeMap.3 \
+ MooseX::Getopt::Strict.3
+
+post-extract:
+ @${PERL} -i -ne 'print unless m,build_requires,' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-Getopt/distinfo b/devel/p5-MooseX-Getopt/distinfo
new file mode 100644
index 000000000000..bb9364a5978c
--- /dev/null
+++ b/devel/p5-MooseX-Getopt/distinfo
@@ -0,0 +1,3 @@
+MD5 (MooseX-Getopt-0.15.tar.gz) = b3269f83b588f1bdcbe25ea450ec3b96
+SHA256 (MooseX-Getopt-0.15.tar.gz) = 3af1824700becc39661c1477b003bd4f45e65edeb79818d8376fa3d24bde9503
+SIZE (MooseX-Getopt-0.15.tar.gz) = 29288
diff --git a/devel/p5-MooseX-Getopt/pkg-descr b/devel/p5-MooseX-Getopt/pkg-descr
new file mode 100644
index 000000000000..d2240747fcf4
--- /dev/null
+++ b/devel/p5-MooseX-Getopt/pkg-descr
@@ -0,0 +1,9 @@
+This is a role which provides an alternate constructor for creating objects
+using parameters passed in from the command line.
+
+This module attempts to DWIM as much as possible with the command line params
+by introspecting your class's attributes. It will use the name of your
+attribute as the command line option, and if there is a type constraint
+defined, it will configure Getopt::Long to handle the option accordingly.
+
+WWW: http://search.cpan.org/dist/MooseX-Getopt/
diff --git a/devel/p5-MooseX-Getopt/pkg-plist b/devel/p5-MooseX-Getopt/pkg-plist
new file mode 100644
index 000000000000..1d344344dc28
--- /dev/null
+++ b/devel/p5-MooseX-Getopt/pkg-plist
@@ -0,0 +1,15 @@
+%%SITE_PERL%%/MooseX/Getopt.pm
+%%SITE_PERL%%/MooseX/Getopt/Meta/Attribute.pm
+%%SITE_PERL%%/MooseX/Getopt/Meta/Attribute/NoGetopt.pm
+%%SITE_PERL%%/MooseX/Getopt/Meta/Attribute/Trait.pm
+%%SITE_PERL%%/MooseX/Getopt/Meta/Attribute/Trait/NoGetopt.pm
+%%SITE_PERL%%/MooseX/Getopt/OptionTypeMap.pm
+%%SITE_PERL%%/MooseX/Getopt/Strict.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Getopt/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Getopt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX
+@dirrmtry %%SITE_PERL%%/MooseX/Getopt/Meta/Attribute/Trait
+@dirrmtry %%SITE_PERL%%/MooseX/Getopt/Meta/Attribute
+@dirrmtry %%SITE_PERL%%/MooseX/Getopt/Meta
+@dirrmtry %%SITE_PERL%%/MooseX/Getopt
+@dirrmtry %%SITE_PERL%%/MooseX