aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-MooseX-Log-Log4perl
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2009-02-25 12:55:16 +0000
committerLars Thegler <lth@FreeBSD.org>2009-02-25 12:55:16 +0000
commit63c035eed9c57c429ac138c878bb8c4030e78a0e (patch)
tree43f4e0610fc753934c62b1b3a7f49a0ef295516c /devel/p5-MooseX-Log-Log4perl
parentd9364ca40426df177c604fa186c412bab3dca044 (diff)
Notes
Diffstat (limited to 'devel/p5-MooseX-Log-Log4perl')
-rw-r--r--devel/p5-MooseX-Log-Log4perl/Makefile29
-rw-r--r--devel/p5-MooseX-Log-Log4perl/distinfo3
-rw-r--r--devel/p5-MooseX-Log-Log4perl/pkg-descr4
-rw-r--r--devel/p5-MooseX-Log-Log4perl/pkg-plist7
4 files changed, 43 insertions, 0 deletions
diff --git a/devel/p5-MooseX-Log-Log4perl/Makefile b/devel/p5-MooseX-Log-Log4perl/Makefile
new file mode 100644
index 000000000000..e06f04570593
--- /dev/null
+++ b/devel/p5-MooseX-Log-Log4perl/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: devel/p5-MooseX-Log-Log4perl
+# Date created: 25 February 2009
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MooseX-Log-Log4perl
+PORTVERSION= 0.31
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= A logging role for Moose based on Log::Log4perl
+
+RUN_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= MooseX::Log::Log4perl.3 \
+ MooseX::Log::Log4perl::Easy.3
+
+post-patch:
+ @${PERL} -pi -e '$$_="" if m/auto_install/' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-Log-Log4perl/distinfo b/devel/p5-MooseX-Log-Log4perl/distinfo
new file mode 100644
index 000000000000..8471c83ff58f
--- /dev/null
+++ b/devel/p5-MooseX-Log-Log4perl/distinfo
@@ -0,0 +1,3 @@
+MD5 (MooseX-Log-Log4perl-0.31.tar.gz) = 302a2413b6faeff398cdb0a9f267e8d6
+SHA256 (MooseX-Log-Log4perl-0.31.tar.gz) = 641a278a4d26755b39a38010f1ae162f2e9a642976ec4d90eae0f8be5f074731
+SIZE (MooseX-Log-Log4perl-0.31.tar.gz) = 21625
diff --git a/devel/p5-MooseX-Log-Log4perl/pkg-descr b/devel/p5-MooseX-Log-Log4perl/pkg-descr
new file mode 100644
index 000000000000..94e18e3d4b97
--- /dev/null
+++ b/devel/p5-MooseX-Log-Log4perl/pkg-descr
@@ -0,0 +1,4 @@
+A logging role building a very lightweight wrapper to Log::Log4perl
+for use with your Moose classes.
+
+WWW: http://search.cpan.org/dist/MooseX-Log-Log4perl/
diff --git a/devel/p5-MooseX-Log-Log4perl/pkg-plist b/devel/p5-MooseX-Log-Log4perl/pkg-plist
new file mode 100644
index 000000000000..44e127914b98
--- /dev/null
+++ b/devel/p5-MooseX-Log-Log4perl/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/MooseX/Log/Log4perl/Easy.pm
+%%SITE_PERL%%/MooseX/Log/Log4perl.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Log/Log4perl/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Log/Log4perl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Log
+@dirrmtry %%SITE_PERL%%/MooseX/Log/Log4perl
+@dirrmtry %%SITE_PERL%%/MooseX/Log