aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Mouse
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2009-04-10 08:43:11 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2009-04-10 08:43:11 +0000
commit68511a508fe92a2965edeb97167352507171aa40 (patch)
treebb232e3752d45d0f2670c7a7f23bd5a244aa618f /devel/p5-Mouse
parentd20e448acd8a30ac2de3c08e2b611f900223efa5 (diff)
downloadports-68511a508fe92a2965edeb97167352507171aa40.tar.gz
ports-68511a508fe92a2965edeb97167352507171aa40.zip
Notes
Diffstat (limited to 'devel/p5-Mouse')
-rw-r--r--devel/p5-Mouse/Makefile3
-rw-r--r--devel/p5-Mouse/distinfo6
-rw-r--r--devel/p5-Mouse/pkg-descr16
-rw-r--r--devel/p5-Mouse/pkg-plist2
4 files changed, 15 insertions, 12 deletions
diff --git a/devel/p5-Mouse/Makefile b/devel/p5-Mouse/Makefile
index e5f00a762b7e..104b29c54497 100644
--- a/devel/p5-Mouse/Makefile
+++ b/devel/p5-Mouse/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Mouse
-PORTVERSION= 0.19
+PORTVERSION= 0.20
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../by-authors/id/S/SA/SARTAK
@@ -20,6 +20,7 @@ PERL_CONFIGURE= 5.8.5+
MAN3= Mouse.3 \
Mouse::Meta::Attribute.3 \
Mouse::Meta::Class.3 \
+ Mouse::Meta::TypeConstraint.3 \
Mouse::Object.3 \
Mouse::Role.3 \
Mouse::Util.3 \
diff --git a/devel/p5-Mouse/distinfo b/devel/p5-Mouse/distinfo
index 7cf40c2ccc2e..6a7ac931d4de 100644
--- a/devel/p5-Mouse/distinfo
+++ b/devel/p5-Mouse/distinfo
@@ -1,3 +1,3 @@
-MD5 (Mouse-0.19.tar.gz) = eb21c9fbf790421a3358e3cbdb92ae5f
-SHA256 (Mouse-0.19.tar.gz) = 61a889ca192ab7b2355115d36729457be74af1aa74f3a36c176618d194caea85
-SIZE (Mouse-0.19.tar.gz) = 79492
+MD5 (Mouse-0.20.tar.gz) = 3e5238e6de46591ae276b14d7269b956
+SHA256 (Mouse-0.20.tar.gz) = 6b765207e22ff935fba178faa7278a032cc0b5179ec4167f3d309990508b3659
+SIZE (Mouse-0.20.tar.gz) = 110057
diff --git a/devel/p5-Mouse/pkg-descr b/devel/p5-Mouse/pkg-descr
index ba502e7d60da..bd3ff99536c9 100644
--- a/devel/p5-Mouse/pkg-descr
+++ b/devel/p5-Mouse/pkg-descr
@@ -1,11 +1,11 @@
-Moose is wonderful.
+Moose is wonderful. Use Moose instead of Mouse!
-Unfortunately, it's a little slow. Though significant progress has been made
-over the years, the compile time penalty is a non-starter for some applications.
+Unfortunately, Moose has a compile-time penalty. Though significant progress has
+been made over the years, the compile time penalty is a non-starter for some
+applications.
Mouse aims to alleviate this by providing a subset of Moose's functionality,
-faster. In particular, "has" in Moose is missing only a few expert-level
-features.
+faster.
Compatibility with Moose has been the utmost concern. Fewer than 1% of the
tests fail when run against Moose instead of Mouse. Mouse code coverage is also
@@ -14,9 +14,9 @@ runs the test suite 3x-4x faster.
The idea is that, if you need the extra power, you should be able to run
s/Mouse/Moose/g on your codebase and have nothing break. To that end,
-nothingmuch has written Squirrel (part of this distribution) which will act as
-Mouse unless Moose is loaded, in which case it will act as Moose.
-
+we have written Any::Moose which will act as Mouse unless Moose is loaded,
+in which case it will act as Moose.
+
Mouse also has the blessings of Moose's author, stevan.
WWW: http://search.cpan.org/dist/Mouse/
diff --git a/devel/p5-Mouse/pkg-plist b/devel/p5-Mouse/pkg-plist
index 51f102496f6b..d29e5dfcd3b7 100644
--- a/devel/p5-Mouse/pkg-plist
+++ b/devel/p5-Mouse/pkg-plist
@@ -1,9 +1,11 @@
%%SITE_PERL%%/Mouse.pm
%%SITE_PERL%%/Mouse/Meta/Attribute.pm
%%SITE_PERL%%/Mouse/Meta/Class.pm
+%%SITE_PERL%%/Mouse/Meta/Method/Accessor.pm
%%SITE_PERL%%/Mouse/Meta/Method/Constructor.pm
%%SITE_PERL%%/Mouse/Meta/Method/Destructor.pm
%%SITE_PERL%%/Mouse/Meta/Role.pm
+%%SITE_PERL%%/Mouse/Meta/TypeConstraint.pm
%%SITE_PERL%%/Mouse/Object.pm
%%SITE_PERL%%/Mouse/Role.pm
%%SITE_PERL%%/Mouse/Tiny.pm