aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Mouse
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2008-07-23 08:06:03 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2008-07-23 08:06:03 +0000
commit05bd1ac14eb6358a07edb30701efdbec14bd0d71 (patch)
tree1b16d8398610d7e7333bca3b0f8aa4c260d96289 /devel/p5-Mouse
parent71dc6f234c8179f31ca9fd3f18f2ee9a9c37b32d (diff)
downloadports-05bd1ac14eb6358a07edb30701efdbec14bd0d71.tar.gz
ports-05bd1ac14eb6358a07edb30701efdbec14bd0d71.zip
Notes
Diffstat (limited to 'devel/p5-Mouse')
-rw-r--r--devel/p5-Mouse/Makefile37
-rw-r--r--devel/p5-Mouse/distinfo3
-rw-r--r--devel/p5-Mouse/pkg-descr22
-rw-r--r--devel/p5-Mouse/pkg-plist14
4 files changed, 76 insertions, 0 deletions
diff --git a/devel/p5-Mouse/Makefile b/devel/p5-Mouse/Makefile
new file mode 100644
index 000000000000..1b5a962491a2
--- /dev/null
+++ b/devel/p5-Mouse/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: devel/p5-Mouse
+# Date created: 23 Jul 2008
+# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mouse
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/S/SA/SARTAK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Moose minus the antlers
+
+RUN_DEPENDS= \
+ p5-Sub-Exporter>=0.972:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-MRO-Compat>=0:${PORTSDIR}/devel/p5-MRO-Compat \
+ p5-Class-Method-Modifiers>=1.01:${PORTSDIR}/devel/p5-Class-Method-Modifiers
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= Mouse.3 \
+ Mouse::Meta::Attribute.3 \
+ Mouse::Meta::Class.3 \
+ Mouse::Object.3 \
+ Mouse::Role.3 \
+ Mouse::TypeRegistry.3 \
+ Squirrel.3
+
+post-extract:
+ @${PERL} -i -ne 'print unless m,build_requires,' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Mouse/distinfo b/devel/p5-Mouse/distinfo
new file mode 100644
index 000000000000..84eab28dda0d
--- /dev/null
+++ b/devel/p5-Mouse/distinfo
@@ -0,0 +1,3 @@
+MD5 (Mouse-0.05.tar.gz) = c06f814e561a72ace4744652eab23a83
+SHA256 (Mouse-0.05.tar.gz) = c23f40f3d82116e34cea2fcd66df3dd3922169fedd50e05802f790c667e98e46
+SIZE (Mouse-0.05.tar.gz) = 38003
diff --git a/devel/p5-Mouse/pkg-descr b/devel/p5-Mouse/pkg-descr
new file mode 100644
index 000000000000..ba502e7d60da
--- /dev/null
+++ b/devel/p5-Mouse/pkg-descr
@@ -0,0 +1,22 @@
+Moose is wonderful.
+
+Unfortunately, it's a little slow. Though significant progress has been made
+over the years, the compile time penalty is a non-starter for some applications.
+
+Mouse aims to alleviate this by providing a subset of Moose's functionality,
+faster. In particular, "has" in Moose is missing only a few expert-level
+features.
+
+Compatibility with Moose has been the utmost concern. Fewer than 1% of the
+tests fail when run against Moose instead of Mouse. Mouse code coverage is also
+over 97%. Even the error messages are taken from Moose. The Mouse code just
+runs the test suite 3x-4x faster.
+
+The idea is that, if you need the extra power, you should be able to run
+s/Mouse/Moose/g on your codebase and have nothing break. To that end,
+nothingmuch has written Squirrel (part of this distribution) which will act as
+Mouse unless Moose is loaded, in which case it will act as Moose.
+
+Mouse also has the blessings of Moose's author, stevan.
+
+WWW: http://search.cpan.org/dist/Mouse/
diff --git a/devel/p5-Mouse/pkg-plist b/devel/p5-Mouse/pkg-plist
new file mode 100644
index 000000000000..0965d91f78de
--- /dev/null
+++ b/devel/p5-Mouse/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/Mouse.pm
+%%SITE_PERL%%/Mouse/Meta/Attribute.pm
+%%SITE_PERL%%/Mouse/Meta/Class.pm
+%%SITE_PERL%%/Mouse/Meta/Role.pm
+%%SITE_PERL%%/Mouse/Object.pm
+%%SITE_PERL%%/Mouse/Role.pm
+%%SITE_PERL%%/Mouse/TypeRegistry.pm
+%%SITE_PERL%%/Squirrel.pm
+%%SITE_PERL%%/Squirrel/Role.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mouse/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Mouse
+@dirrmtry %%SITE_PERL%%/Mouse/Meta
+@dirrmtry %%SITE_PERL%%/Mouse
+@dirrmtry %%SITE_PERL%%/Squirrel