aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Net-DBus
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-11-25 14:10:45 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-11-25 14:10:45 +0000
commit1c1dc248e533d8cbf39de6772401b8d69c7d89f6 (patch)
treef28d367845e89577eb70e20158045acc82fac9cd /devel/p5-Net-DBus
parenta66a28cbd38747cf707eb1026f13243db6e619c1 (diff)
downloadports-1c1dc248e533d8cbf39de6772401b8d69c7d89f6.tar.gz
ports-1c1dc248e533d8cbf39de6772401b8d69c7d89f6.zip
Notes
Diffstat (limited to 'devel/p5-Net-DBus')
-rw-r--r--devel/p5-Net-DBus/Makefile31
-rw-r--r--devel/p5-Net-DBus/distinfo3
-rw-r--r--devel/p5-Net-DBus/pkg-descr6
-rw-r--r--devel/p5-Net-DBus/pkg-plist34
4 files changed, 74 insertions, 0 deletions
diff --git a/devel/p5-Net-DBus/Makefile b/devel/p5-Net-DBus/Makefile
new file mode 100644
index 000000000000..75991ed9eee1
--- /dev/null
+++ b/devel/p5-Net-DBus/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Net-DBus
+# Date created: 2005-11-25
+# Whom: Roman Bogorodskiy <novel@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-DBus
+PORTVERSION= 0.32.2
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= novel@FreeBSD.org
+COMMENT= Perl extension for the DBus message system
+
+LIB_DEPENDS= dbus-1.1:${PORTSDIR}/devel/dbus
+
+USE_GNOME= pkgconfig
+PERL_CONFIGURE= yes
+
+MAN3= Net::DBus::Tutorial.3 Net::DBus::RemoteObject.3 \
+ Net::DBus::Binding::Connection.3 Net::DBus::RemoteService.3 \
+ Net::DBus::Tutorial::ExportingObjects.3 Net::DBus::Dumper.3 \
+ Net::DBus::Binding::Iterator.3 Net::DBus::Binding::Message.3 \
+ Net::DBus::Binding::Server.3 Net::DBus::Service.3 \
+ Net::DBus.3 Net::DBus::Object.3 Net::DBus::Reactor.3 \
+ Net::DBus::Exporter.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Net-DBus/distinfo b/devel/p5-Net-DBus/distinfo
new file mode 100644
index 000000000000..f6ee0217d15a
--- /dev/null
+++ b/devel/p5-Net-DBus/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-DBus-0.32.2.tar.gz) = 07c1b2b986db39ef96ba2055cf0b1759
+SHA256 (Net-DBus-0.32.2.tar.gz) = 7f15457cee790039645baedd5c2003ebbcce00b2eb461d930bf1593031f3534f
+SIZE (Net-DBus-0.32.2.tar.gz) = 58479
diff --git a/devel/p5-Net-DBus/pkg-descr b/devel/p5-Net-DBus/pkg-descr
new file mode 100644
index 000000000000..de9bc7c6a902
--- /dev/null
+++ b/devel/p5-Net-DBus/pkg-descr
@@ -0,0 +1,6 @@
+Net::DBus provides a Perl XS API to the dbus inter-application
+messaging system. The Perl API covers the core base level
+of the dbus APIs, not concerning itself yet with the GLib
+or QT wrappers
+
+WWW: http://search.cpan.org/dist/Net-DBus/
diff --git a/devel/p5-Net-DBus/pkg-plist b/devel/p5-Net-DBus/pkg-plist
new file mode 100644
index 000000000000..79ae4e440953
--- /dev/null
+++ b/devel/p5-Net-DBus/pkg-plist
@@ -0,0 +1,34 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DBus/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DBus/DBus.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DBus/DBus.so
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/RemoteObject.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Service.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Object.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Tutorial.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/RemoteService.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Dumper.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Callback.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Exporter.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Reactor.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Binding/Watch.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Binding/Bus.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Binding/Connection.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Binding/Iterator.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Binding/Message.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Binding/Introspector.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Binding/Server.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Binding/Message/Signal.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Binding/Message/MethodReturn.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Binding/Message/MethodCall.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Binding/Message/Error.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Tutorial/ExportingObjects.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DBus
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Binding/Message
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Binding
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus/Tutorial
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Net/DBus
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Net/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true