aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-No-Worries
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2013-01-08 09:13:09 +0000
committerAnton Berezin <tobez@FreeBSD.org>2013-01-08 09:13:09 +0000
commita424db8b4c5c22311f91d0ac47a8bdda78905170 (patch)
treecf425c67289f8402725bd4e0ecb2467fdc14090f /devel/p5-No-Worries
parentd35eb69f7ca54b7417ce0c959c451eea4bb5ed6c (diff)
downloadports-a424db8b4c5c22311f91d0ac47a8bdda78905170.tar.gz
ports-a424db8b4c5c22311f91d0ac47a8bdda78905170.zip
Notes
Diffstat (limited to 'devel/p5-No-Worries')
-rw-r--r--devel/p5-No-Worries/Makefile35
-rw-r--r--devel/p5-No-Worries/distinfo2
-rw-r--r--devel/p5-No-Worries/pkg-descr4
-rw-r--r--devel/p5-No-Worries/pkg-plist19
4 files changed, 60 insertions, 0 deletions
diff --git a/devel/p5-No-Worries/Makefile b/devel/p5-No-Worries/Makefile
new file mode 100644
index 000000000000..6b493e45fb73
--- /dev/null
+++ b/devel/p5-No-Worries/Makefile
@@ -0,0 +1,35 @@
+# Created by: Anton Berezin <tobez@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= No-Worries
+PORTVERSION= 0.8
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= No::Worries - coding without worries
+
+BUILD_DEPENDS= p5-HTTP-Date>=0:${PORTSDIR}/www/p5-HTTP-Date \
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= No::Worries.3 \
+ No::Worries::DN.3 \
+ No::Worries::Date.3 \
+ No::Worries::Die.3 \
+ No::Worries::Dir.3 \
+ No::Worries::Export.3 \
+ No::Worries::File.3 \
+ No::Worries::Log.3 \
+ No::Worries::PidFile.3 \
+ No::Worries::Proc.3 \
+ No::Worries::Stat.3 \
+ No::Worries::String.3 \
+ No::Worries::Syslog.3 \
+ No::Worries::Warn.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-No-Worries/distinfo b/devel/p5-No-Worries/distinfo
new file mode 100644
index 000000000000..64fa456e161f
--- /dev/null
+++ b/devel/p5-No-Worries/distinfo
@@ -0,0 +1,2 @@
+SHA256 (No-Worries-0.8.tar.gz) = 8c9a00d691ca16876d160de312279120e035a89f6ff74bbc7062e20d2f6b6a04
+SIZE (No-Worries-0.8.tar.gz) = 39139
diff --git a/devel/p5-No-Worries/pkg-descr b/devel/p5-No-Worries/pkg-descr
new file mode 100644
index 000000000000..45458401d1ac
--- /dev/null
+++ b/devel/p5-No-Worries/pkg-descr
@@ -0,0 +1,4 @@
+This collection of modules ease coding by providing consistent
+convenient functions to perform frequently used programming tasks.
+
+WWW: http://search.cpan.org/dist/No-Worries/
diff --git a/devel/p5-No-Worries/pkg-plist b/devel/p5-No-Worries/pkg-plist
new file mode 100644
index 000000000000..99a20913622c
--- /dev/null
+++ b/devel/p5-No-Worries/pkg-plist
@@ -0,0 +1,19 @@
+%%SITE_PERL%%/No/Worries.pm
+%%SITE_PERL%%/No/Worries/DN.pm
+%%SITE_PERL%%/No/Worries/Date.pm
+%%SITE_PERL%%/No/Worries/Die.pm
+%%SITE_PERL%%/No/Worries/Dir.pm
+%%SITE_PERL%%/No/Worries/Export.pm
+%%SITE_PERL%%/No/Worries/File.pm
+%%SITE_PERL%%/No/Worries/Log.pm
+%%SITE_PERL%%/No/Worries/PidFile.pm
+%%SITE_PERL%%/No/Worries/Proc.pm
+%%SITE_PERL%%/No/Worries/Stat.pm
+%%SITE_PERL%%/No/Worries/String.pm
+%%SITE_PERL%%/No/Worries/Syslog.pm
+%%SITE_PERL%%/No/Worries/Warn.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/No/Worries/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/No/Worries
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/No
+@dirrmtry %%SITE_PERL%%/No/Worries
+@dirrmtry %%SITE_PERL%%/No