aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-OOTools/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-07-22 14:27:46 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-07-22 14:27:46 +0000
commitb109c6a5bd5fef7e5fe71587ee10c50f9bbf5132 (patch)
tree28d6491f6d5f48330db0182c09f17cabe089792d /devel/p5-OOTools/Makefile
parentd602d43d81f247ef2ed4f1f2b594451e05a79925 (diff)
Notes
Diffstat (limited to 'devel/p5-OOTools/Makefile')
-rw-r--r--devel/p5-OOTools/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/p5-OOTools/Makefile b/devel/p5-OOTools/Makefile
new file mode 100644
index 000000000000..07172b6b412a
--- /dev/null
+++ b/devel/p5-OOTools/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: OOTools
+# Date created: July 22 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= OOTools
+PORTVERSION= 1.75
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/D/DO/DOMIZIO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= A Perl module collection to easily create constructors methods
+
+PERL_CONFIGURE= YES
+
+MAN3= Class::constr.3 \
+ Class::groups.3 \
+ Class::props.3 \
+ Object::groups.3 \
+ Object::props.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.1 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>