aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-ORBit
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-03-12 08:58:27 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-03-12 08:58:27 +0000
commit13034831632b982d6f60b4a7f3fe706d5ec5a276 (patch)
treeac9781983e8b1e8bf8041609a8b87a68cf774119 /devel/p5-ORBit
parent284ac44553f2a2313c23eb41b1bdea49c7c4f56b (diff)
downloadports-13034831632b982d6f60b4a7f3fe706d5ec5a276.tar.gz
ports-13034831632b982d6f60b4a7f3fe706d5ec5a276.zip
Notes
Diffstat (limited to 'devel/p5-ORBit')
-rw-r--r--devel/p5-ORBit/Makefile31
-rw-r--r--devel/p5-ORBit/distinfo1
-rw-r--r--devel/p5-ORBit/pkg-comment1
-rw-r--r--devel/p5-ORBit/pkg-descr1
-rw-r--r--devel/p5-ORBit/pkg-plist13
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-ORBit/Makefile b/devel/p5-ORBit/Makefile
new file mode 100644
index 000000000000..e0b424c7530f
--- /dev/null
+++ b/devel/p5-ORBit/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-ORBit
+# Date created: 11 March 2001
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= ORBit
+PORTVERSION= 0.4.3
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CORBA
+PKGNAMEPREFIX= p5-
+DISTNAME= CORBA-ORBit-${PORTVERSION}
+
+MAINTAINER= vanilla@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Error.pm:${PORTSDIR}/lang/p5-Error
+LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= CORBA::ORBit.3 \
+ CORBA::ORBit::Fixed.3 \
+ CORBA::ORBit::LongDouble.3 \
+ CORBA::ORBit::LongLong.3 \
+ CORBA::ORBit::ULongLong.3 \
+ CORBA::ORBit::mapping.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-ORBit/distinfo b/devel/p5-ORBit/distinfo
new file mode 100644
index 000000000000..f251ef085f0f
--- /dev/null
+++ b/devel/p5-ORBit/distinfo
@@ -0,0 +1 @@
+MD5 (CORBA-ORBit-0.4.3.tar.gz) = 17910897d32d9bbedad745fe3fa1b94a
diff --git a/devel/p5-ORBit/pkg-comment b/devel/p5-ORBit/pkg-comment
new file mode 100644
index 000000000000..83254afff035
--- /dev/null
+++ b/devel/p5-ORBit/pkg-comment
@@ -0,0 +1 @@
+The perl binding for ORBit
diff --git a/devel/p5-ORBit/pkg-descr b/devel/p5-ORBit/pkg-descr
new file mode 100644
index 000000000000..10f6bed1cc30
--- /dev/null
+++ b/devel/p5-ORBit/pkg-descr
@@ -0,0 +1 @@
+The perl binding for ORBit.
diff --git a/devel/p5-ORBit/pkg-plist b/devel/p5-ORBit/pkg-plist
new file mode 100644
index 000000000000..66018d578d5e
--- /dev/null
+++ b/devel/p5-ORBit/pkg-plist
@@ -0,0 +1,13 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA/ORBit.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA/ORBit/Fixed.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA/ORBit/LongDouble.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA/ORBit/LongLong.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA/ORBit/ULongLong.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA/ORBit/mapping.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CORBA/ORBit/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CORBA/ORBit/ORBit.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CORBA/ORBit/ORBit.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CORBA/ORBit
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CORBA
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA/ORBit
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA