aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Object-Destroyer
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-24 05:31:08 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-24 05:31:08 +0000
commite2915a9c814a2c0c076dbb05239b4f748195d55a (patch)
tree7918c92ca02ef8526dcc50bdc8ebf8a3f97a7d8a /devel/p5-Object-Destroyer
parentb74de8c1dd0f64059706b9b7c1e850616a573818 (diff)
Notes
Diffstat (limited to 'devel/p5-Object-Destroyer')
-rw-r--r--devel/p5-Object-Destroyer/Makefile21
-rw-r--r--devel/p5-Object-Destroyer/distinfo2
-rw-r--r--devel/p5-Object-Destroyer/pkg-descr10
-rw-r--r--devel/p5-Object-Destroyer/pkg-plist6
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/p5-Object-Destroyer/Makefile b/devel/p5-Object-Destroyer/Makefile
new file mode 100644
index 000000000000..6282480a81e3
--- /dev/null
+++ b/devel/p5-Object-Destroyer/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Object-Destroyer
+# Date created: 2010-11-16
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Object-Destroyer
+PORTVERSION= 2.00
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Make objects with circular references DESTROY normally
+
+PERL_CONFIGURE= yes
+
+MAN3= Object::Destroyer.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Object-Destroyer/distinfo b/devel/p5-Object-Destroyer/distinfo
new file mode 100644
index 000000000000..81a3fbbf5da4
--- /dev/null
+++ b/devel/p5-Object-Destroyer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Object-Destroyer-2.00.tar.gz) = 651c126d9e6b48d62ae7bcd752ea50f5c53503c1f9e9a0451147cad83b93e940
+SIZE (Object-Destroyer-2.00.tar.gz) = 29001
diff --git a/devel/p5-Object-Destroyer/pkg-descr b/devel/p5-Object-Destroyer/pkg-descr
new file mode 100644
index 000000000000..462a1189ebd6
--- /dev/null
+++ b/devel/p5-Object-Destroyer/pkg-descr
@@ -0,0 +1,10 @@
+Object::Destroyer allows for the creation of "Destroy" handles. The
+handle is "attached" to the circular relationship, but is not a part
+of it. When the destroy handle falls out of scope, it will be cleaned
+up correctly, and while being cleaned up, it will also force the data
+structure it is attached to to be destroyed as well. Object::Destroyer
+can call a specified release method on an object (or method DESTROY by
+default). Alternatively, it can execute an arbitrary user code passed
+to constructor as a code reference.
+
+WWW: http://search.cpan.org/dist/Object-Destroyer/
diff --git a/devel/p5-Object-Destroyer/pkg-plist b/devel/p5-Object-Destroyer/pkg-plist
new file mode 100644
index 000000000000..ee982bc78876
--- /dev/null
+++ b/devel/p5-Object-Destroyer/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Object/Destroyer/.packlist
+%%SITE_PERL%%/Object/Destroyer.pm
+@dirrmtry %%SITE_PERL%%/Object
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Object/Destroyer
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Object