aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-PCSC-Card/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-04-20 12:42:06 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-04-20 12:42:06 +0000
commit384c2bae3b94d68ec15491eba4dc6c00acfb93ea (patch)
treefa1875a4f3aa5c20bbc367e43e857f6c786b914f /devel/p5-PCSC-Card/Makefile
parent2a7193c97879226f0631d791aecbcac01770058f (diff)
downloadports-384c2bae3b94d68ec15491eba4dc6c00acfb93ea.tar.gz
ports-384c2bae3b94d68ec15491eba4dc6c00acfb93ea.zip
Notes
Diffstat (limited to 'devel/p5-PCSC-Card/Makefile')
-rw-r--r--devel/p5-PCSC-Card/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/devel/p5-PCSC-Card/Makefile b/devel/p5-PCSC-Card/Makefile
index c6faa1d2b48a..796f63eb04d2 100644
--- a/devel/p5-PCSC-Card/Makefile
+++ b/devel/p5-PCSC-Card/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= PCSC-Card
-PORTVERSION= 1.2.2
+PORTVERSION= 1.4.2
CATEGORIES= devel perl5
MASTER_SITES= http://ludovic.rousseau.free.fr/softwares/pcsc-perl/
PKGNAMEPREFIX= p5-
@@ -15,7 +15,9 @@ DISTNAME= pcsc-perl-${PORTVERSION}
MAINTAINER= bms@FreeBSD.org
COMMENT= Perl bindings for the PC/SC Lite Framework
-LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
+
+USE_REINPLACE= yes
.include <bsd.port.pre.mk>
@@ -30,4 +32,9 @@ MAKE_ENV= "LOCALBASE=$(LOCALBASE)"
MAN3= Chipcard::PCSC::Card.3 Chipcard::PCSC.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+post-patch:
+ ${REINPLACE_CMD} -e "s,-I/usr/local/pcsc/include,${LOCALBASE}/include/PCSC," \
+ ${WRKSRC}/Makefile.PL
+
+
.include <bsd.port.post.mk>