aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-PCSC-Card
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-04-20 12:42:06 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-04-20 12:42:06 +0000
commit384c2bae3b94d68ec15491eba4dc6c00acfb93ea (patch)
treefa1875a4f3aa5c20bbc367e43e857f6c786b914f /devel/p5-PCSC-Card
parent2a7193c97879226f0631d791aecbcac01770058f (diff)
downloadports-384c2bae3b94d68ec15491eba4dc6c00acfb93ea.tar.gz
ports-384c2bae3b94d68ec15491eba4dc6c00acfb93ea.zip
Notes
Diffstat (limited to 'devel/p5-PCSC-Card')
-rw-r--r--devel/p5-PCSC-Card/Makefile11
-rw-r--r--devel/p5-PCSC-Card/distinfo4
-rw-r--r--devel/p5-PCSC-Card/files/patch-Makefile.PL11
3 files changed, 11 insertions, 15 deletions
diff --git a/devel/p5-PCSC-Card/Makefile b/devel/p5-PCSC-Card/Makefile
index c6faa1d2b48a..796f63eb04d2 100644
--- a/devel/p5-PCSC-Card/Makefile
+++ b/devel/p5-PCSC-Card/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= PCSC-Card
-PORTVERSION= 1.2.2
+PORTVERSION= 1.4.2
CATEGORIES= devel perl5
MASTER_SITES= http://ludovic.rousseau.free.fr/softwares/pcsc-perl/
PKGNAMEPREFIX= p5-
@@ -15,7 +15,9 @@ DISTNAME= pcsc-perl-${PORTVERSION}
MAINTAINER= bms@FreeBSD.org
COMMENT= Perl bindings for the PC/SC Lite Framework
-LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
+
+USE_REINPLACE= yes
.include <bsd.port.pre.mk>
@@ -30,4 +32,9 @@ MAKE_ENV= "LOCALBASE=$(LOCALBASE)"
MAN3= Chipcard::PCSC::Card.3 Chipcard::PCSC.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+post-patch:
+ ${REINPLACE_CMD} -e "s,-I/usr/local/pcsc/include,${LOCALBASE}/include/PCSC," \
+ ${WRKSRC}/Makefile.PL
+
+
.include <bsd.port.post.mk>
diff --git a/devel/p5-PCSC-Card/distinfo b/devel/p5-PCSC-Card/distinfo
index f1fc7c16f31f..528ddd0e25fc 100644
--- a/devel/p5-PCSC-Card/distinfo
+++ b/devel/p5-PCSC-Card/distinfo
@@ -1,2 +1,2 @@
-MD5 (pcsc-perl-1.2.2.tar.gz) = ec590bd7c14f265eaaac5d209b89c3b5
-SIZE (pcsc-perl-1.2.2.tar.gz) = 38616
+MD5 (pcsc-perl-1.4.2.tar.gz) = 76f55845a4601605be9ee7d57254c32d
+SIZE (pcsc-perl-1.4.2.tar.gz) = 41532
diff --git a/devel/p5-PCSC-Card/files/patch-Makefile.PL b/devel/p5-PCSC-Card/files/patch-Makefile.PL
deleted file mode 100644
index 17738c5fa518..000000000000
--- a/devel/p5-PCSC-Card/files/patch-Makefile.PL
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.PL.orig Tue May 27 20:31:10 2003
-+++ Makefile.PL Mon Sep 29 03:09:07 2003
-@@ -6,7 +6,7 @@
- 'VERSION_FROM' => 'PCSC.pm', # finds $VERSION
- 'LIBS' => [''], # e.g., '-lm'
- 'DEFINE' => '-O2 -Wall', # e.g., '-DHAVE_SOMETHING'
-- 'INC' => '-I/usr/local/pcsc/include', # e.g., '-I/usr/include/other'
-+ 'INC' => '-I$(LOCALBASE)/include', # e.g., '-I/usr/include/other'
- 'PL_FILES' => {},
- );
-