aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-POE-API-Hooks/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-10-17 16:15:43 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-10-17 16:15:43 +0000
commitce2e8d9327e63b162c5eb15aa41bfecf00f5db72 (patch)
tree9aa4432939b0f83512d0aed5d3846f0928eb09c0 /devel/p5-POE-API-Hooks/Makefile
parent233e1f99c390eb37e71e832bd8e33907a7a0cb9a (diff)
Notes
Diffstat (limited to 'devel/p5-POE-API-Hooks/Makefile')
-rw-r--r--devel/p5-POE-API-Hooks/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/p5-POE-API-Hooks/Makefile b/devel/p5-POE-API-Hooks/Makefile
new file mode 100644
index 000000000000..9f9805752aa4
--- /dev/null
+++ b/devel/p5-POE-API-Hooks/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: POE-API-Hooks
+# Date created: 17 October 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-API-Hooks
+PORTVERSION= 1.0404
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/S/SU/SUNGO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Implement lightweight hooks into POE
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::API::Hooks.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= "Perl 5.6.1 or newer required. Install lang/perl5 or lang/perl5.8 and try again."
+.endif
+
+.include <bsd.port.post.mk>