aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-POE-Component-DirWatch/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-07-06 10:10:09 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-07-06 10:10:09 +0000
commit332edaba36942c6c131a3ad703b8a67244bd5a1e (patch)
tree789b3329c7f7ae9608d253158e00ae40173418c7 /devel/p5-POE-Component-DirWatch/Makefile
parent7792e121bcb7099020ef01a6d6f5327c1e824361 (diff)
downloadports-332edaba36942c6c131a3ad703b8a67244bd5a1e.tar.gz
ports-332edaba36942c6c131a3ad703b8a67244bd5a1e.zip
Notes
Diffstat (limited to 'devel/p5-POE-Component-DirWatch/Makefile')
-rw-r--r--devel/p5-POE-Component-DirWatch/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/p5-POE-Component-DirWatch/Makefile b/devel/p5-POE-Component-DirWatch/Makefile
new file mode 100644
index 000000000000..5d6f5d2d26cf
--- /dev/null
+++ b/devel/p5-POE-Component-DirWatch/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: POE-Component-DirWatch
+# Date created: 06 July 2002
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-DirWatch
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/POE.pm:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= POE::Component::DirWatch.3
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/eg/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>