aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-POE-XS-Loop-Poll/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-07-09 20:25:53 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-07-09 20:25:53 +0000
commit228dc722c7b3d37a90535e1c18f22ff06f236170 (patch)
treeddbd3bffb889ce028692160359495e4869ca075a /devel/p5-POE-XS-Loop-Poll/Makefile
parentc9f1f55b1942a17fb3bb9dcf26b28f3ea0b0591e (diff)
downloadports-228dc722c7b3d37a90535e1c18f22ff06f236170.tar.gz
ports-228dc722c7b3d37a90535e1c18f22ff06f236170.zip
Notes
Diffstat (limited to 'devel/p5-POE-XS-Loop-Poll/Makefile')
-rw-r--r--devel/p5-POE-XS-Loop-Poll/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/p5-POE-XS-Loop-Poll/Makefile b/devel/p5-POE-XS-Loop-Poll/Makefile
new file mode 100644
index 000000000000..f97f607124fd
--- /dev/null
+++ b/devel/p5-POE-XS-Loop-Poll/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-POE-XS-Loop-Poll
+# Date created: 03 July 2008
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-XS-Loop-Poll
+PORTVERSION= 0.004
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= XS implementation of POE::Loop, using poll(2)
+
+BUILD_DEPENDS= ${SITE_PERL}/POE/Test/Loops.pm:${PORTSDIR}/devel/p5-POE-Test-Loops
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CONFIGURE_SCRIPT+= Makefile.PL --default
+
+MAN3= POE::XS::Loop::Poll.3
+
+.include <bsd.port.mk>