aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-POE
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2008-06-03 11:36:59 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2008-06-03 11:36:59 +0000
commitdedb6cef76e3d48ff108a95ef950de31730c6175 (patch)
treeb93ce524f228beb6129c3c8f4d2ef37762db15c7 /devel/p5-POE
parenta9eddb8c4ca2393aa9b5b37e3b5293f08d32e574 (diff)
downloadports-dedb6cef76e3d48ff108a95ef950de31730c6175.tar.gz
ports-dedb6cef76e3d48ff108a95ef950de31730c6175.zip
Notes
Diffstat (limited to 'devel/p5-POE')
-rw-r--r--devel/p5-POE/Makefile40
-rw-r--r--devel/p5-POE/distinfo6
-rw-r--r--devel/p5-POE/pkg-plist3
3 files changed, 22 insertions, 27 deletions
diff --git a/devel/p5-POE/Makefile b/devel/p5-POE/Makefile
index 952b3c917c98..57cf8d47057a 100644
--- a/devel/p5-POE/Makefile
+++ b/devel/p5-POE/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= POE
-PORTVERSION= 0.9999
+PORTVERSION= 1.0002
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,12 +14,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Multitasking and networking framework for perl
-BUILD_DEPENDS= \
- ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
${SITE_PERL}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event \
${SITE_PERL}/${PERL_ARCH}/Filter/Util/Call.pm:${PORTSDIR}/devel/p5-Filter \
+ ${SITE_PERL}/${PERL_ARCH}/IO.pm:${PORTSDIR}/devel/p5-IO \
${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -27,25 +27,23 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
CONFIGURE_ARGS= --default
-MAN3= POE.3 POE::API::Ctl.3 POE::API::ResLoader.3 POE::Component.3 \
- POE::Component::Client::TCP.3 POE::Component::Server::TCP.3 \
- POE::Driver.3 POE::Driver::SysRW.3 POE::Filter.3 \
- POE::Filter::Block.3 POE::Filter::Grep.3 POE::Filter::HTTPD.3 \
- POE::Filter::Line.3 POE::Filter::Map.3 \
- POE::Filter::RecordBlock.3 POE::Filter::Reference.3 \
- POE::Filter::Stackable.3 POE::Filter::Stream.3 POE::Kernel.3 \
- POE::Loop.3 POE::Loop::Event.3 POE::Loop::Gtk.3 \
- POE::Loop::IO_Poll.3 POE::Loop::PerlSignals.3 \
- POE::Loop::Select.3 POE::Loop::Tk.3 POE::Loop::TkActiveState.3 \
- POE::Loop::TkCommon.3 POE::NFA.3 POE::Pipe.3 \
- POE::Pipe::OneWay.3 POE::Pipe::TwoWay.3 \
+MAN3= POE.3 POE::Component.3 POE::Component::Client::TCP.3 \
+ POE::Component::Server::TCP.3 POE::Driver.3 \
+ POE::Driver::SysRW.3 POE::Filter.3 POE::Filter::Block.3 \
+ POE::Filter::Grep.3 POE::Filter::HTTPD.3 POE::Filter::Line.3 \
+ POE::Filter::Map.3 POE::Filter::RecordBlock.3 \
+ POE::Filter::Reference.3 POE::Filter::Stackable.3 \
+ POE::Filter::Stream.3 POE::Kernel.3 POE::Loop.3 \
+ POE::Loop::Event.3 POE::Loop::Gtk.3 POE::Loop::IO_Poll.3 \
+ POE::Loop::PerlSignals.3 POE::Loop::Select.3 POE::Loop::Tk.3 \
+ POE::Loop::TkActiveState.3 POE::Loop::TkCommon.3 POE::NFA.3 \
+ POE::Pipe.3 POE::Pipe::OneWay.3 POE::Pipe::TwoWay.3 \
POE::Queue.3 POE::Queue::Array.3 POE::Resource.3 \
- POE::Resource::Aliases.3 POE::Resource::Controls.3 \
- POE::Resource::Events.3 POE::Resource::Extrefs.3 \
- POE::Resource::FileHandles.3 POE::Resource::SIDs.3 \
- POE::Resource::Sessions.3 POE::Resource::Signals.3 \
- POE::Resource::Statistics.3 POE::Resources.3 \
- POE::Session.3 POE::Wheel.3 \
+ POE::Resource::Aliases.3 POE::Resource::Events.3 \
+ POE::Resource::Extrefs.3 POE::Resource::FileHandles.3 \
+ POE::Resource::SIDs.3 POE::Resource::Sessions.3 \
+ POE::Resource::Signals.3 POE::Resource::Statistics.3 \
+ POE::Resources.3 POE::Session.3 POE::Wheel.3 \
POE::Wheel::Curses.3 POE::Wheel::FollowTail.3 \
POE::Wheel::ListenAccept.3 POE::Wheel::ReadLine.3 \
POE::Wheel::ReadWrite.3 POE::Wheel::Run.3 \
diff --git a/devel/p5-POE/distinfo b/devel/p5-POE/distinfo
index 5b4e1f1a760d..2ac8a3233d02 100644
--- a/devel/p5-POE/distinfo
+++ b/devel/p5-POE/distinfo
@@ -1,3 +1,3 @@
-MD5 (POE-0.9999.tar.gz) = 6672a43075cd597ed1011db5b45f1f1d
-SHA256 (POE-0.9999.tar.gz) = 994e17322593d464bfc2bbdfb3b8cabfde4032dbe30d2ce50f698302391d5c7e
-SIZE (POE-0.9999.tar.gz) = 358389
+MD5 (POE-1.0002.tar.gz) = 75e2124ed59c15de16ecb640b50486c0
+SHA256 (POE-1.0002.tar.gz) = c954f9f28662005fbfb875bf41e0effa3bf9936c4d48c792d9d44c84f9b0c51b
+SIZE (POE-1.0002.tar.gz) = 367038
diff --git a/devel/p5-POE/pkg-plist b/devel/p5-POE/pkg-plist
index 255998c72295..bf3c61f5db6c 100644
--- a/devel/p5-POE/pkg-plist
+++ b/devel/p5-POE/pkg-plist
@@ -1,7 +1,5 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/.packlist
%%SITE_PERL%%/POE.pm
-%%SITE_PERL%%/POE/API/Ctl.pm
-%%SITE_PERL%%/POE/API/ResLoader.pm
%%SITE_PERL%%/POE/Component.pm
%%SITE_PERL%%/POE/Component/Client/TCP.pm
%%SITE_PERL%%/POE/Component/Server/TCP.pm
@@ -35,7 +33,6 @@
%%SITE_PERL%%/POE/Queue/Array.pm
%%SITE_PERL%%/POE/Resource.pm
%%SITE_PERL%%/POE/Resource/Aliases.pm
-%%SITE_PERL%%/POE/Resource/Controls.pm
%%SITE_PERL%%/POE/Resource/Events.pm
%%SITE_PERL%%/POE/Resource/Extrefs.pm
%%SITE_PERL%%/POE/Resource/FileHandles.pm