aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-POEx-Role-SessionInstantiation
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-10-10 01:15:10 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-10-10 01:15:10 +0000
commitd7dc9dd769edd95edc3723516a808013d98078a0 (patch)
treebfdd8f5ac797c2db6d902fe4a81ebc1f32601569 /devel/p5-POEx-Role-SessionInstantiation
parent9b520c54e407f88fb8bd2a21001f4ab3501d8fbb (diff)
downloadports-d7dc9dd769edd95edc3723516a808013d98078a0.tar.gz
ports-d7dc9dd769edd95edc3723516a808013d98078a0.zip
Notes
Diffstat (limited to 'devel/p5-POEx-Role-SessionInstantiation')
-rw-r--r--devel/p5-POEx-Role-SessionInstantiation/Makefile38
-rw-r--r--devel/p5-POEx-Role-SessionInstantiation/distinfo3
-rw-r--r--devel/p5-POEx-Role-SessionInstantiation/pkg-descr11
-rw-r--r--devel/p5-POEx-Role-SessionInstantiation/pkg-plist14
4 files changed, 66 insertions, 0 deletions
diff --git a/devel/p5-POEx-Role-SessionInstantiation/Makefile b/devel/p5-POEx-Role-SessionInstantiation/Makefile
new file mode 100644
index 000000000000..6bf5bcfc42d9
--- /dev/null
+++ b/devel/p5-POEx-Role-SessionInstantiation/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: POEx::Role::SessionInstantiation
+# Date created: 10 Oct 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POEx-Role-SessionInstantiation
+PORTVERSION= 1.102610
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/N/NP/NPEREZ
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension of Moose role for turning objects into POE sessions
+
+RUN_DEPENDS= \
+ p5-MooseX-CompileTime-Traits>=0:${PORTSDIR}/devel/p5-MooseX-CompileTime-Traits \
+ p5-MooseX-Declare>0:${PORTSDIR}/devel/p5-MooseX-Declare \
+ p5-MooseX-Types>0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-MooseX-Types>0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-POE>0:${PORTSDIR}/devel/p5-POE \
+ p5-POEx-Types>=0:${PORTSDIR}/devel/p5-POEx-Types \
+ p5-aliased>0:${PORTSDIR}/devel/p5-aliased
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POEx::Role::Event.3 \
+ POEx::Role::SessionInstantiation.3 \
+ POEx::Role::SessionInstantiation::Meta::POEState.3 \
+ POEx::Role::SessionInstantiation::Meta::Session::Events.3 \
+ POEx::Role::SessionInstantiation::Meta::Session::Implementation.3 \
+ POEx::Role::SessionInstantiation::Meta::Session::Magic.3 \
+ POEx::Role::SessionInstantiation::Meta::Session::Sugar.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-POEx-Role-SessionInstantiation/distinfo b/devel/p5-POEx-Role-SessionInstantiation/distinfo
new file mode 100644
index 000000000000..f616073f66b2
--- /dev/null
+++ b/devel/p5-POEx-Role-SessionInstantiation/distinfo
@@ -0,0 +1,3 @@
+MD5 (POEx-Role-SessionInstantiation-1.102610.tar.gz) = eec75436e518c6546df2e85eac29778d
+SHA256 (POEx-Role-SessionInstantiation-1.102610.tar.gz) = a6e3c523998869e8dd30b91d91f1248ac44360aa7caec74e204128bf839fd5a9
+SIZE (POEx-Role-SessionInstantiation-1.102610.tar.gz) = 19895
diff --git a/devel/p5-POEx-Role-SessionInstantiation/pkg-descr b/devel/p5-POEx-Role-SessionInstantiation/pkg-descr
new file mode 100644
index 000000000000..04cf4b43a168
--- /dev/null
+++ b/devel/p5-POEx-Role-SessionInstantiation/pkg-descr
@@ -0,0 +1,11 @@
+POEx::Role::SessionInstantiation provides a nearly seamless
+integration for non-POE objects into a POE environment. It does this
+by handling the POE stuff behind the scenes including allowing per
+instances method changes, session registration to the Kernel, and
+providing some defaults like setting an alias if supplied via the
+attribute or constructor argument, or defining a _default that warns
+if your object receives an event that it does not have.
+
+This role exposes your class' methods as POE events.
+
+WWW: http://search.cpan.org/dist/POEx-Role-SessionInstantiation/
diff --git a/devel/p5-POEx-Role-SessionInstantiation/pkg-plist b/devel/p5-POEx-Role-SessionInstantiation/pkg-plist
new file mode 100644
index 000000000000..49730539e5d3
--- /dev/null
+++ b/devel/p5-POEx-Role-SessionInstantiation/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POEx/Role/SessionInstantiation/.packlist
+%%SITE_PERL%%/POEx/Role/Event.pm
+%%SITE_PERL%%/POEx/Role/SessionInstantiation.pm
+%%SITE_PERL%%/POEx/Role/SessionInstantiation/Meta/POEState.pm
+%%SITE_PERL%%/POEx/Role/SessionInstantiation/Meta/Session/Events.pm
+%%SITE_PERL%%/POEx/Role/SessionInstantiation/Meta/Session/Implementation.pm
+%%SITE_PERL%%/POEx/Role/SessionInstantiation/Meta/Session/Magic.pm
+%%SITE_PERL%%/POEx/Role/SessionInstantiation/Meta/Session/Sugar.pm
+@dirrm %%SITE_PERL%%/POEx/Role/SessionInstantiation/Meta/Session
+@dirrm %%SITE_PERL%%/POEx/Role/SessionInstantiation/Meta
+@dirrm %%SITE_PERL%%/POEx/Role/SessionInstantiation
+@dirrmtry %%SITE_PERL%%/POEx/Role
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POEx/Role/SessionInstantiation
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POEx/Role