aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Parallel-Iterator
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2010-10-07 00:21:56 +0000
committerSahil Tandon <sahil@FreeBSD.org>2010-10-07 00:21:56 +0000
commit75bc8633f379dfd61cf17eabea6b5d0dc5d2c977 (patch)
tree7622d9cd3343e1f8305ca40fa65f1b12637b8839 /devel/p5-Parallel-Iterator
parent8e0c198f864611cd663879f07167acf4d7ae86a0 (diff)
Notes
Diffstat (limited to 'devel/p5-Parallel-Iterator')
-rw-r--r--devel/p5-Parallel-Iterator/Makefile21
-rw-r--r--devel/p5-Parallel-Iterator/distinfo3
-rw-r--r--devel/p5-Parallel-Iterator/pkg-descr5
-rw-r--r--devel/p5-Parallel-Iterator/pkg-plist2
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/p5-Parallel-Iterator/Makefile b/devel/p5-Parallel-Iterator/Makefile
new file mode 100644
index 000000000000..c4ebed0c2eb7
--- /dev/null
+++ b/devel/p5-Parallel-Iterator/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Parallel-Iterator
+# Date created: 2010-09-30
+# Whom: Frederic Culot <frederic@culot.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parallel-Iterator
+PORTVERSION= 1.00
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= frederic@culot.org
+COMMENT= Simple parallel execution
+
+PERL_MODBUILD= 5.8.0+
+
+MAN3= Parallel::Iterator.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Parallel-Iterator/distinfo b/devel/p5-Parallel-Iterator/distinfo
new file mode 100644
index 000000000000..55e128e1b60d
--- /dev/null
+++ b/devel/p5-Parallel-Iterator/distinfo
@@ -0,0 +1,3 @@
+MD5 (Parallel-Iterator-1.00.tar.gz) = 879051d329ea79f59eb4b03bb0bf7c87
+SHA256 (Parallel-Iterator-1.00.tar.gz) = e8495095cf5746a14e154037b11b0d911da2a32283b77291abb37bf6311345f4
+SIZE (Parallel-Iterator-1.00.tar.gz) = 15227
diff --git a/devel/p5-Parallel-Iterator/pkg-descr b/devel/p5-Parallel-Iterator/pkg-descr
new file mode 100644
index 000000000000..51cc7a6831ca
--- /dev/null
+++ b/devel/p5-Parallel-Iterator/pkg-descr
@@ -0,0 +1,5 @@
+This module provides a 'parallel map'. Multiple worker processes are
+forked so that many instances of the transformation function may be
+executed simultaneously.
+
+WWW: http://search.cpan.org/dist/Parallel-Iterator/
diff --git a/devel/p5-Parallel-Iterator/pkg-plist b/devel/p5-Parallel-Iterator/pkg-plist
new file mode 100644
index 000000000000..417e0d84b46f
--- /dev/null
+++ b/devel/p5-Parallel-Iterator/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Parallel/Iterator.pm
+@dirrmtry %%SITE_PERL%%/Parallel