aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Parallel-Scoreboard
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2011-12-31 08:29:14 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2011-12-31 08:29:14 +0000
commit3485e3880ecf7f20fafd0b8e020481992e63c548 (patch)
tree4526145b8357edc187c6fb681f3eb106b6999a05 /devel/p5-Parallel-Scoreboard
parent5237b4926432a093919fccb359df42c79947ab5c (diff)
Notes
Diffstat (limited to 'devel/p5-Parallel-Scoreboard')
-rw-r--r--devel/p5-Parallel-Scoreboard/Makefile29
-rw-r--r--devel/p5-Parallel-Scoreboard/distinfo2
-rw-r--r--devel/p5-Parallel-Scoreboard/pkg-descr11
-rw-r--r--devel/p5-Parallel-Scoreboard/pkg-plist10
4 files changed, 52 insertions, 0 deletions
diff --git a/devel/p5-Parallel-Scoreboard/Makefile b/devel/p5-Parallel-Scoreboard/Makefile
new file mode 100644
index 000000000000..ef1c2b260e73
--- /dev/null
+++ b/devel/p5-Parallel-Scoreboard/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Parallel::Scoreboard
+# Date created: 31 Dec 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parallel-Scoreboard
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension of scoreboard for monitoring status of many workers
+
+RUN_DEPENDS= \
+ p5-Class-Accessor-Lite>=0.05:${PORTSDIR}/devel/p5-Class-Accessor-Lite \
+ p5-HTML-Parser>0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-JSON>0:${PORTSDIR}/converters/p5-JSON
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Parallel::Scoreboard.3 \
+ Parallel::Scoreboard::PSGI::App.3 \
+ Parallel::Scoreboard::PSGI::App::JSON.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Parallel-Scoreboard/distinfo b/devel/p5-Parallel-Scoreboard/distinfo
new file mode 100644
index 000000000000..4a9bc0fa9fd2
--- /dev/null
+++ b/devel/p5-Parallel-Scoreboard/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Parallel-Scoreboard-0.03.tar.gz) = 49ced2db78e478647cdbd7f77c24d96c2f26d91cd98c31616befe3a709959dc0
+SIZE (Parallel-Scoreboard-0.03.tar.gz) = 60146
diff --git a/devel/p5-Parallel-Scoreboard/pkg-descr b/devel/p5-Parallel-Scoreboard/pkg-descr
new file mode 100644
index 000000000000..e8ca818a8c64
--- /dev/null
+++ b/devel/p5-Parallel-Scoreboard/pkg-descr
@@ -0,0 +1,11 @@
+Parallel::Scoreboard is a pure-perl implementation of a process
+scoreboard. By using the module it is easy to create a monitor for
+many worker process, like the status module of the Apache HTTP server.
+
+Unlike other similar modules, Parallel::Scoreboard is easy to use and
+has no limitation on the format or the length of the statuses to be
+stored. Any arbitrary data (like JSON or frozen perl object) can be
+saved by the worker processes as their status and read from the
+manager process.
+
+WWW: http://search.cpan.org/dist/Parallel-Scoreboard/
diff --git a/devel/p5-Parallel-Scoreboard/pkg-plist b/devel/p5-Parallel-Scoreboard/pkg-plist
new file mode 100644
index 000000000000..4a441d56c341
--- /dev/null
+++ b/devel/p5-Parallel-Scoreboard/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parallel/Scoreboard/.packlist
+%%SITE_PERL%%/Parallel/Scoreboard.pm
+%%SITE_PERL%%/Parallel/Scoreboard/PSGI/App.pm
+%%SITE_PERL%%/Parallel/Scoreboard/PSGI/App/JSON.pm
+@dirrm %%SITE_PERL%%/Parallel/Scoreboard/PSGI/App
+@dirrm %%SITE_PERL%%/Parallel/Scoreboard/PSGI
+@dirrm %%SITE_PERL%%/Parallel/Scoreboard
+@dirrmtry %%SITE_PERL%%/Parallel
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parallel/Scoreboard
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parallel