aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Parse-ErrorString-Perl
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-15 17:11:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-15 17:11:22 +0000
commit3080a20cfbc4c5db786a3546ba37a0d3a463ce03 (patch)
treeac82909acec847bc5dd0fb8ae6020cbe8fc1a5c1 /devel/p5-Parse-ErrorString-Perl
parent21e82a3c446acacb93d223b4c0fa263dcbd18d4d (diff)
Notes
Diffstat (limited to 'devel/p5-Parse-ErrorString-Perl')
-rw-r--r--devel/p5-Parse-ErrorString-Perl/Makefile27
-rw-r--r--devel/p5-Parse-ErrorString-Perl/distinfo3
-rw-r--r--devel/p5-Parse-ErrorString-Perl/pkg-descr4
-rw-r--r--devel/p5-Parse-ErrorString-Perl/pkg-plist9
4 files changed, 43 insertions, 0 deletions
diff --git a/devel/p5-Parse-ErrorString-Perl/Makefile b/devel/p5-Parse-ErrorString-Perl/Makefile
new file mode 100644
index 000000000000..49192cbcb0b2
--- /dev/null
+++ b/devel/p5-Parse-ErrorString-Perl/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Parse-ErrorString-Perl
+# Date created: March 8th 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parse-ErrorString-Perl
+PORTVERSION= 0.13
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= Parse error messages from the Perl interpreter
+
+BUILD_DEPENDS= ${SITE_PERL}/Pod/POM.pm:${PORTSDIR}/textproc/p5-Pod-POM \
+ ${SITE_PERL}/Test/Differences.pm:${PORTSDIR}/devel/p5-Test-Differences \
+ ${SITE_PERL}/${PERL_ARCH}/Class/XSAccessor.pm:${PORTSDIR}/devel/p5-Class-XSAccessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN1= check_perldiag.1
+MAN3= Parse::ErrorString::Perl.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Parse-ErrorString-Perl/distinfo b/devel/p5-Parse-ErrorString-Perl/distinfo
new file mode 100644
index 000000000000..cd5a5c028149
--- /dev/null
+++ b/devel/p5-Parse-ErrorString-Perl/distinfo
@@ -0,0 +1,3 @@
+MD5 (Parse-ErrorString-Perl-0.13.tar.gz) = 8a8f41f78ea552914953d47f75dcbf5e
+SHA256 (Parse-ErrorString-Perl-0.13.tar.gz) = ccdd936c4febeff91bc52264244180e5f1a34f771fc44e78e87d9fcfb80d7aff
+SIZE (Parse-ErrorString-Perl-0.13.tar.gz) = 11579
diff --git a/devel/p5-Parse-ErrorString-Perl/pkg-descr b/devel/p5-Parse-ErrorString-Perl/pkg-descr
new file mode 100644
index 000000000000..c1d48228fce7
--- /dev/null
+++ b/devel/p5-Parse-ErrorString-Perl/pkg-descr
@@ -0,0 +1,4 @@
+Parse::ErrorString::Perl is a module for parsing Perl interpreter
+error messages.
+
+WWW: http://search.cpan.org/dist/Parse-ErrorString-Perl/
diff --git a/devel/p5-Parse-ErrorString-Perl/pkg-plist b/devel/p5-Parse-ErrorString-Perl/pkg-plist
new file mode 100644
index 000000000000..4e05aa2b7842
--- /dev/null
+++ b/devel/p5-Parse-ErrorString-Perl/pkg-plist
@@ -0,0 +1,9 @@
+bin/check_perldiag
+%%SITE_PERL%%/Parse/ErrorString/Perl.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/ErrorString/Perl/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/ErrorString/Perl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/ErrorString
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/Parse/ErrorString
+@dirrmtry %%SITE_PERL%%/Parse