aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-ParseLex/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-08-21 10:59:35 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-08-21 10:59:35 +0000
commit57a3e704b38590181a7c921e6fe39110c60ee9ab (patch)
tree07622e33fd27879a2e54677cc933571619fbe38a /devel/p5-ParseLex/Makefile
parent5f99dd95e8b0c74c93a3ae0918fb1e104f51a4ab (diff)
downloadports-57a3e704b38590181a7c921e6fe39110c60ee9ab.tar.gz
ports-57a3e704b38590181a7c921e6fe39110c60ee9ab.zip
Notes
Diffstat (limited to 'devel/p5-ParseLex/Makefile')
-rw-r--r--devel/p5-ParseLex/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/p5-ParseLex/Makefile b/devel/p5-ParseLex/Makefile
new file mode 100644
index 000000000000..e60eaeb65ea2
--- /dev/null
+++ b/devel/p5-ParseLex/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-ParseLex
+# Date created: 16 February 2004
+# Whom: Jim Pirzyk <pirzyk@uiuc.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ParseLex
+PORTVERSION= 2.15
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Parse
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pirzyk@freebsd.org
+COMMENT= Object-oriented generator of lexical analyzers
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Parse::Lex.3 Parse::Token.3 Parse::YYLex.3 Parse::LexEvent.3 Parse::CLex.3 Parse::Template.3
+
+post-patch:
+ @${RM} ${WRKSRC}/lib/Parse/*.orig
+
+.include <bsd.port.mk>