aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Proc-PID-File
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-05-06 12:25:51 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-05-06 12:25:51 +0000
commit00337b72173321bfdfb24f9add4cef39935cab33 (patch)
tree4c06bd016f37cc4d19f396aac94802655535baea /devel/p5-Proc-PID-File
parent74e3abdd2d2fbb959d9cb400014b6d9b2c573f28 (diff)
downloadports-00337b72173321bfdfb24f9add4cef39935cab33.tar.gz
ports-00337b72173321bfdfb24f9add4cef39935cab33.zip
Notes
Diffstat (limited to 'devel/p5-Proc-PID-File')
-rw-r--r--devel/p5-Proc-PID-File/Makefile32
-rw-r--r--devel/p5-Proc-PID-File/distinfo2
-rw-r--r--devel/p5-Proc-PID-File/pkg-descr9
-rw-r--r--devel/p5-Proc-PID-File/pkg-plist7
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/p5-Proc-PID-File/Makefile b/devel/p5-Proc-PID-File/Makefile
new file mode 100644
index 000000000000..1fa3e740325c
--- /dev/null
+++ b/devel/p5-Proc-PID-File/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Proc-PID-File
+# Date created: Apr 13 2004
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+
+PORTNAME= Proc-PID-File
+PORTVERSION= 1.24
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Proc
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= A module to manage process id files
+
+PERL_CONFIGURE= yes
+
+MAN3= Proc::PID::File.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} <= 500503
+post-patch:
+ @${PERL} -pi -e '$$_ = "" if /no warnings/' ${WRKSRC}/File.pm
+
+# make PREFIX-clean under perl 5.005_03
+post-configure:
+ @${PERL} -pi -e 's,/usr/local/,\$$(PREFIX)/,g' ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Proc-PID-File/distinfo b/devel/p5-Proc-PID-File/distinfo
new file mode 100644
index 000000000000..c3c70f7cb631
--- /dev/null
+++ b/devel/p5-Proc-PID-File/distinfo
@@ -0,0 +1,2 @@
+MD5 (Proc-PID-File-1.24.tar.gz) = 90b636492ae72def975a9ef9cac90fda
+SIZE (Proc-PID-File-1.24.tar.gz) = 12214
diff --git a/devel/p5-Proc-PID-File/pkg-descr b/devel/p5-Proc-PID-File/pkg-descr
new file mode 100644
index 000000000000..d9cd7c69bef3
--- /dev/null
+++ b/devel/p5-Proc-PID-File/pkg-descr
@@ -0,0 +1,9 @@
+This Perl module is useful for writers of daemons and other processes
+that need to tell whether they are already running, in order to
+prevent multiple process instances. The module accomplishes this
+via *nix-style pidfiles, which are files that store a process
+identifier.
+
+Inspired by Proc::PID_File, but with a much simpler interface.
+
+WWW: http://search.cpan.org/dist/Proc-PID-File/
diff --git a/devel/p5-Proc-PID-File/pkg-plist b/devel/p5-Proc-PID-File/pkg-plist
new file mode 100644
index 000000000000..28b9e847d88c
--- /dev/null
+++ b/devel/p5-Proc-PID-File/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Proc/PID/File.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/PID/File/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/PID/File
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/PID 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Proc/PID 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Proc 2>/dev/null || true