aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Proc-Reliable
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-23 12:44:07 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-23 12:44:07 +0000
commitab8f528661da5f6b0890f04a551add3703454558 (patch)
treefacc2a1f350db196a8c50b9cd7512c461231aa9a /devel/p5-Proc-Reliable
parent679d45e9885a94232ba648264d95bf26b37be416 (diff)
downloadports-ab8f528661da5f6b0890f04a551add3703454558.tar.gz
ports-ab8f528661da5f6b0890f04a551add3703454558.zip
Notes
Diffstat (limited to 'devel/p5-Proc-Reliable')
-rw-r--r--devel/p5-Proc-Reliable/Makefile22
-rw-r--r--devel/p5-Proc-Reliable/distinfo1
-rw-r--r--devel/p5-Proc-Reliable/pkg-comment1
-rw-r--r--devel/p5-Proc-Reliable/pkg-descr11
-rw-r--r--devel/p5-Proc-Reliable/pkg-plist8
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/p5-Proc-Reliable/Makefile b/devel/p5-Proc-Reliable/Makefile
new file mode 100644
index 000000000000..d7080a95de94
--- /dev/null
+++ b/devel/p5-Proc-Reliable/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Proc::Reliable
+# Date created: 31 Dec 2001
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Proc-Reliable
+PORTVERSION= 1.10
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Proc
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+PERL_CONFIGURE= yes
+
+MAN3= Proc::Reliable.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Proc-Reliable/distinfo b/devel/p5-Proc-Reliable/distinfo
new file mode 100644
index 000000000000..c98010863088
--- /dev/null
+++ b/devel/p5-Proc-Reliable/distinfo
@@ -0,0 +1 @@
+MD5 (Proc-Reliable-1.10.tar.gz) = 3c1e9b2ba6d7f6986b17975a6a14aa44
diff --git a/devel/p5-Proc-Reliable/pkg-comment b/devel/p5-Proc-Reliable/pkg-comment
new file mode 100644
index 000000000000..aa85687ff011
--- /dev/null
+++ b/devel/p5-Proc-Reliable/pkg-comment
@@ -0,0 +1 @@
+Run external processes reliably with many options
diff --git a/devel/p5-Proc-Reliable/pkg-descr b/devel/p5-Proc-Reliable/pkg-descr
new file mode 100644
index 000000000000..fa5384708027
--- /dev/null
+++ b/devel/p5-Proc-Reliable/pkg-descr
@@ -0,0 +1,11 @@
+The Proc::Reliable is intended to be a method for simple, reliable
+and configurable subprocess execution in PERL. It includes all the
+functionality of the backticks operator and system() functions,
+plus many uses of fork/exec, open2() and open3(). Proc::Reliable
+incorporates a number of options, including sending data to the
+subprocess on STDIN, collecting STDOUT and STDERR separately or
+together, killing hung processes, timouts and automatic retries.
+
+WWW: http://search.cpan.org/search?dist=Proc-Reliable
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/devel/p5-Proc-Reliable/pkg-plist b/devel/p5-Proc-Reliable/pkg-plist
new file mode 100644
index 000000000000..efb480c75b2d
--- /dev/null
+++ b/devel/p5-Proc-Reliable/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/Proc/Reliable.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Proc/Reliable/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Proc/Reliable/.packlist
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Proc 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Proc/Reliable
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/Proc 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Proc/Reliable
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Proc 2>/dev/null || true