aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Readonly/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-02 14:34:46 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-02 14:34:46 +0000
commit01ecdb749dd6708a2512f73580e7ed39219f751f (patch)
tree691038d0d7c99631470656bf9858ced53138571d /devel/p5-Readonly/Makefile
parent302b5111c44bb75485503f1aed7f2577a798261e (diff)
downloadports-01ecdb749dd6708a2512f73580e7ed39219f751f.tar.gz
ports-01ecdb749dd6708a2512f73580e7ed39219f751f.zip
Notes
Diffstat (limited to 'devel/p5-Readonly/Makefile')
-rw-r--r--devel/p5-Readonly/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/devel/p5-Readonly/Makefile b/devel/p5-Readonly/Makefile
index 47c9a8312bf4..b3dfbd81b9e2 100644
--- a/devel/p5-Readonly/Makefile
+++ b/devel/p5-Readonly/Makefile
@@ -7,23 +7,25 @@
PORTNAME= Readonly
PORTVERSION= 1.03
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/R/RO/ROODE
PKGNAMEPREFIX= p5-
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${PORTNAME}-XS-${PORTVERSION}${EXTRACT_SUFX}
+ ${PORTNAME}-XS-${PORTVERSION_XS}${EXTRACT_SUFX}
MAINTAINER= skv@FreeBSD.org
COMMENT= Facility for creating read-only scalars, arrays, hashes
PERL_CONFIGURE= yes
-CONFIGURE_ARGS= DIR="${PORTNAME}-XS-${PORTVERSION}"
+CONFIGURE_ARGS= DIR="${PORTNAME}-XS-${PORTVERSION_XS}"
+PORTVERSION_XS= 1.04
MAN3= Readonly.3 Readonly::XS.3
post-patch:
- ${MV} ${WRKDIR}/${PORTNAME}-XS-${PORTVERSION} ${WRKSRC}
+ ${MV} ${WRKDIR}/${PORTNAME}-XS-${PORTVERSION_XS} ${WRKSRC}
${RM} ${WRKSRC}/*.pl
.include <bsd.port.pre.mk>