aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-ResourcePool
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-09 15:16:24 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-09 15:16:24 +0000
commit45924720fda4d30489e83722d947c5c8380613b1 (patch)
treef80a875956974cd3212913309554fec521d2041e /devel/p5-ResourcePool
parent265a8e937cab0082929ea3af089cf692766d8ac9 (diff)
downloadports-45924720fda4d30489e83722d947c5c8380613b1.tar.gz
ports-45924720fda4d30489e83722d947c5c8380613b1.zip
Notes
Diffstat (limited to 'devel/p5-ResourcePool')
-rw-r--r--devel/p5-ResourcePool/Makefile32
-rw-r--r--devel/p5-ResourcePool/distinfo1
-rw-r--r--devel/p5-ResourcePool/pkg-comment1
-rw-r--r--devel/p5-ResourcePool/pkg-descr13
-rw-r--r--devel/p5-ResourcePool/pkg-plist17
5 files changed, 64 insertions, 0 deletions
diff --git a/devel/p5-ResourcePool/Makefile b/devel/p5-ResourcePool/Makefile
new file mode 100644
index 000000000000..bb60aaf43683
--- /dev/null
+++ b/devel/p5-ResourcePool/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: p5-ResourcePool
+# Date created: Aug 9, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ResourcePool
+PORTVERSION= 0.9906
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ http://www.fatalmind.com/projects/ResourcePool/
+MASTER_SITE_SUBDIR= ../by-authors/id/M/MW/MWS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+PERL_CONFIGURE= YES
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= ResourcePool.3 \
+ ResourcePool::Factory.3 \
+ ResourcePool::Factory::DBI.3 \
+ ResourcePool::Factory::Net::LDAP.3 \
+ ResourcePool::LoadBalancer.3 \
+ ResourcePool::Resource.3 \
+ ResourcePool::Resource::DBI.3 \
+ ResourcePool::Resource::Net::LDAP.3 \
+ ResourcePool::Singleton.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-ResourcePool/distinfo b/devel/p5-ResourcePool/distinfo
new file mode 100644
index 000000000000..6c2ea298cd72
--- /dev/null
+++ b/devel/p5-ResourcePool/distinfo
@@ -0,0 +1 @@
+MD5 (ResourcePool-0.9906.tar.gz) = 008fff82b43b37a43fa0c5b2294140ca
diff --git a/devel/p5-ResourcePool/pkg-comment b/devel/p5-ResourcePool/pkg-comment
new file mode 100644
index 000000000000..5a27312d5ca4
--- /dev/null
+++ b/devel/p5-ResourcePool/pkg-comment
@@ -0,0 +1 @@
+A generic way to use connection caching for any kind of resources
diff --git a/devel/p5-ResourcePool/pkg-descr b/devel/p5-ResourcePool/pkg-descr
new file mode 100644
index 000000000000..f4c962c90f12
--- /dev/null
+++ b/devel/p5-ResourcePool/pkg-descr
@@ -0,0 +1,13 @@
+The ResourcePool provides a generic way to use connection caching for any
+kind of resources. The package includes classes to deal with DBI and
+Net::LDAP resources and is easily extensible. It has also a LoadBalancer
+class to spread load across different servers and is able to do fail over
+to increase the overall availability of the service.
+
+Use this package if you...
+ ...want to use connection caching (persistent connections) for something
+ which is NOT DBI (e.g. Net::LDAP).
+ ...have more then one server which can handle your requests and need to
+ implement load balancing and/or fail over.
+
+WWW: http://www.fatalmind.com/projects/ResourcePool/
diff --git a/devel/p5-ResourcePool/pkg-plist b/devel/p5-ResourcePool/pkg-plist
new file mode 100644
index 000000000000..ca54eec648a7
--- /dev/null
+++ b/devel/p5-ResourcePool/pkg-plist
@@ -0,0 +1,17 @@
+lib/perl5/site_perl/%%PERL_VER%%/ResourcePool.pm
+lib/perl5/site_perl/%%PERL_VER%%/ResourcePool.pod
+lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Factory.pm
+lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Factory/DBI.pm
+lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Factory/Net/LDAP.pm
+lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/LoadBalancer.pm
+lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Resource.pm
+lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Resource/DBI.pm
+lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Resource/Net/LDAP.pm
+lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Singleton.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Factory/Net
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Factory
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Resource/Net
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Resource
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/ResourcePool
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/ResourcePool/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/ResourcePool