aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Rose-Object/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-06-10 10:45:07 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-06-10 10:45:07 +0000
commite9fda5cbb9ba1848eee0bd3f4d7847ac72a9d3b9 (patch)
tree24b57d0f751e112a59ce9800879953955530ade9 /devel/p5-Rose-Object/Makefile
parent12209a67304396c8f12a9055750be760a48b7ce2 (diff)
downloadports-e9fda5cbb9ba1848eee0bd3f4d7847ac72a9d3b9.tar.gz
ports-e9fda5cbb9ba1848eee0bd3f4d7847ac72a9d3b9.zip
Notes
Diffstat (limited to 'devel/p5-Rose-Object/Makefile')
-rw-r--r--devel/p5-Rose-Object/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/devel/p5-Rose-Object/Makefile b/devel/p5-Rose-Object/Makefile
new file mode 100644
index 000000000000..f66b32a31558
--- /dev/null
+++ b/devel/p5-Rose-Object/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: devel/p5-Rose-Object
+# Date created: 09 June 2006
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Rose-Object
+PORTVERSION= 0.80
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Rose
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= A simple object base class
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= Rose::Class.3 \
+ Rose::Class::MakeMethods::Generic.3 \
+ Rose::Class::MakeMethods::Set.3 \
+ Rose::Object.3 \
+ Rose::Object::MakeMethods.3 \
+ Rose::Object::MakeMethods::DateTime.3 \
+ Rose::Object::MakeMethods::Generic.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>