aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-SDL/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-08-07 14:03:04 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-08-07 14:03:04 +0000
commitf2dd639f5ebf24543d80bf743e2d05ad29092a3d (patch)
treee72e82a442590642bcbc0ee452a80f2548f8ce72 /devel/p5-SDL/Makefile
parent94e9c4a8dbc8cdd6f1b7e4e11a90b9a60b780295 (diff)
downloadports-f2dd639f5ebf24543d80bf743e2d05ad29092a3d.tar.gz
ports-f2dd639f5ebf24543d80bf743e2d05ad29092a3d.zip
Notes
Diffstat (limited to 'devel/p5-SDL/Makefile')
-rw-r--r--devel/p5-SDL/Makefile35
1 files changed, 14 insertions, 21 deletions
diff --git a/devel/p5-SDL/Makefile b/devel/p5-SDL/Makefile
index 4180d92ae99e..cd693a2d2e7a 100644
--- a/devel/p5-SDL/Makefile
+++ b/devel/p5-SDL/Makefile
@@ -4,31 +4,28 @@
# $FreeBSD$
PORTNAME= SDL
-PORTVERSION= 2.2.0
-PORTREVISION= 3
+PORTVERSION= 2.2.6
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= ../../authors/id/D/DG/DGOEHRIG
+MASTER_SITE_SUBDIR=SDL
PKGNAMEPREFIX= p5-
-DISTNAME= SDL_Perl-${PORTVERSION}
+DISTNAME= SDL_Perl-v${PORTVERSION}
MAINTAINER= spam@rm-rf.kiev.ua
COMMENT= Perl Bindings for SDL
+BUILD_DEPENDS= p5-YAML>=0.62:${PORTSDIR}/textproc/p5-YAML
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg
-USE_PERL5= yes
USE_SDL= sdl
PERL_MODBUILD= yes
-BROKEN= does not build
-
OPTIONS= SDL_TTF "Enable TTF support" on \
- SDL_NET "Enable NET support" on \
- SDL_GFX "Enable GFX support" on \
- SDL_IMAGE "Enable IMAGE support" on \
- SDL_MIXER "Enable MIXER support" on
+ SDL_NET "Enable NET support" on \
+ SDL_GFX "Enable GFX support" on \
+ SDL_IMAGE "Enable IMAGE support" on \
+ SDL_MIXER "Enable MIXER support" on
.include <bsd.port.pre.mk>
@@ -63,6 +60,7 @@ MAN3= SDL.3 \
SDL::Cursor.3 \
SDL::Event.3 \
SDL::Font.3 \
+ SDL::Game::Rect.3 \
SDL::MPEG.3 \
SDL::Mixer.3 \
SDL::Music.3 \
@@ -78,23 +76,18 @@ MAN3= SDL.3 \
SDL::Tool::Graphic.3 \
SDL::Tutorial.3 \
SDL::Tutorial::Animation.3 \
- SDL::Tutorial::Images.3 \
SDL::Tutorial::Drawing.3 \
+ SDL::Tutorial::Images.3 \
+ SDL::Tutorial::LunarLander.3 \
SDL::Video.3
-# Workaround for Build.PL bug
post-install:
- if [ -d ${SITE_PERL}/${PERL_ARCH}/auto/src ]; then \
- ${MV} ${SITE_PERL}/${PERL_ARCH}/auto/src/SDL* \
- ${SITE_PERL}/${PERL_ARCH}/auto/; \
- ${RMDIR} ${SITE_PERL}/${PERL_ARCH}/auto/src; \
- fi
-
- if [ -n ${PERL} ]; then \
+ @if [ -n "${PERL}" ]; then \
PERL_THREADED=`${PERL} -V | ${GREP} -- -Dusethreads=y || ${TRUE}`; \
if [ -z ${PERL_THREADED} ]; then \
+ ${ECHO_MSG}; \
${ECHO_MSG} "SDL_PERL must be built with a threaded Perl, reinstall Perl with WITH_THREADS=yes"; \
- ${ECHO_MSG} "or launch any program that use this port with LD_PRELOAD=/usr/lib/libc_r.so"; \
+ ${ECHO_MSG}; \
fi; \
fi