aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-SPOPS
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-05-27 14:21:33 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-05-27 14:21:33 +0000
commitea39d5bc679140bde76aba5e7bb2bf3a894f4fd2 (patch)
treed1166b0718f5c120b0aa65f458b47f2f44934283 /devel/p5-SPOPS
parentb3d64975635daaddf04d03dff77df2ee4cc6bbda (diff)
downloadports-ea39d5bc679140bde76aba5e7bb2bf3a894f4fd2.tar.gz
ports-ea39d5bc679140bde76aba5e7bb2bf3a894f4fd2.zip
Notes
Diffstat (limited to 'devel/p5-SPOPS')
-rw-r--r--devel/p5-SPOPS/Makefile77
-rw-r--r--devel/p5-SPOPS/distinfo1
-rw-r--r--devel/p5-SPOPS/pkg-comment1
-rw-r--r--devel/p5-SPOPS/pkg-descr23
-rw-r--r--devel/p5-SPOPS/pkg-plist128
5 files changed, 230 insertions, 0 deletions
diff --git a/devel/p5-SPOPS/Makefile b/devel/p5-SPOPS/Makefile
new file mode 100644
index 000000000000..812f5068a38e
--- /dev/null
+++ b/devel/p5-SPOPS/Makefile
@@ -0,0 +1,77 @@
+# New ports collection makefile for: SPOPS
+# Date created: 17 Dec 2001
+# Whom: Sergey Skvortsov <skv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SPOPS
+PORTVERSION= 0.61
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN:S|/modules/by-module|/authors/id|}
+MASTER_SITE_SUBDIR= C/CW/CWINTERS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Class/Date.pm:${PORTSDIR}/devel/p5-Class-Date \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Carp/Assert.pm:${PORTSDIR}/devel/p5-Carp-Assert \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/Fields.pm:${PORTSDIR}/devel/p5-Class-Fields \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/Factory.pm:${PORTSDIR}/devel/p5-Class-Factory \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Devel/StackTrace.pm:${PORTSDIR}/devel/p5-Devel-StackTrace \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= </dev/null
+PLIST_SUB+= EXAMPLESDIR="share/examples/${PORTNAME}"
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= SPOPS.3 SPOPS::ClassFactory.3 SPOPS::ClassFactory::DBI.3 \
+ SPOPS::ClassFactory::DefaultBehavior.3 \
+ SPOPS::ClassFactory::LDAP.3 SPOPS::DBI.3 \
+ SPOPS::DBI::InterBase.3 SPOPS::DBI::MySQL.3 \
+ SPOPS::DBI::Oracle.3 SPOPS::DBI::Pg.3 SPOPS::DBI::SQLite.3 \
+ SPOPS::DBI::Sybase.3 SPOPS::Error.3 SPOPS::Exception.3 \
+ SPOPS::Exception::DBI.3 SPOPS::Exception::LDAP.3 \
+ SPOPS::Exception::Security.3 SPOPS::Export.3 \
+ SPOPS::Export::DBI::Data.3 SPOPS::Export::Object.3 \
+ SPOPS::Export::Perl.3 SPOPS::Export::SQL.3 SPOPS::Export::XML.3 \
+ SPOPS::GDBM.3 SPOPS::HashFile.3 SPOPS::Import.3 \
+ SPOPS::Import::DBI::Data.3 SPOPS::Import::DBI::Table.3 \
+ SPOPS::Import::DBI::TableTransform.3 SPOPS::Import::Object.3 \
+ SPOPS::Initialize.3 SPOPS::Iterator.3 SPOPS::Iterator::DBI.3 \
+ SPOPS::Iterator::LDAP.3 SPOPS::Iterator::WrapList.3 \
+ SPOPS::Key::DBI::HandleField.3 SPOPS::Key::DBI::Identity.3 \
+ SPOPS::Key::DBI::Pool.3 SPOPS::Key::DBI::Sequence.3 \
+ SPOPS::Key::Random.3 SPOPS::Key::UUID.3 SPOPS::LDAP.3 \
+ SPOPS::LDAP::MultiDatasource.3 SPOPS::Loopback.3 \
+ SPOPS::Manual.3 SPOPS::Manual::CodeGeneration.3 \
+ SPOPS::Manual::Configuration.3 SPOPS::Manual::Cookbook.3 \
+ SPOPS::Manual::Datasource.3 SPOPS::Manual::Exceptions.3 \
+ SPOPS::Manual::ImportExport.3 SPOPS::Manual::Intro.3 \
+ SPOPS::Manual::Object.3 SPOPS::Manual::ObjectRules.3 \
+ SPOPS::Manual::Relationships.3 SPOPS::Manual::Security.3 \
+ SPOPS::Manual::Serialization.3 SPOPS::SQLInterface.3 \
+ SPOPS::Secure.3 SPOPS::Secure::Hierarchy.3 SPOPS::Tie.3 \
+ SPOPS::Tie::StrictField.3 SPOPS::Tool::DBI::Datasource.3 \
+ SPOPS::Tool::DBI::DiscoverField.3 \
+ SPOPS::Tool::DBI::FindDefaults.3 \
+ SPOPS::Tool::LDAP::Datasource.3 SPOPS::Tool::ReadOnly.3 \
+ SPOPS::Tool::UTFConvert.3 SPOPS::Utility.3
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}/My
+ @${INSTALL_SCRIPT} ${WRKSRC}/eg/*.pl ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/eg/*.sql ${WRKSRC}/eg/README \
+ ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/eg/My/*.pm ${EXAMPLESDIR}/My
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/p5-SPOPS/distinfo b/devel/p5-SPOPS/distinfo
new file mode 100644
index 000000000000..e3988adcf2e2
--- /dev/null
+++ b/devel/p5-SPOPS/distinfo
@@ -0,0 +1 @@
+MD5 (SPOPS-0.61.tar.gz) = 0b156bd7198b203560f311ad5dd75054
diff --git a/devel/p5-SPOPS/pkg-comment b/devel/p5-SPOPS/pkg-comment
new file mode 100644
index 000000000000..28ede5688437
--- /dev/null
+++ b/devel/p5-SPOPS/pkg-comment
@@ -0,0 +1 @@
+Simple Perl Object Persistence with Security
diff --git a/devel/p5-SPOPS/pkg-descr b/devel/p5-SPOPS/pkg-descr
new file mode 100644
index 000000000000..7dae51932f97
--- /dev/null
+++ b/devel/p5-SPOPS/pkg-descr
@@ -0,0 +1,23 @@
+SPOPS is a robust and powerful module that allows you to serialize objects. It
+is unique in that it also allows you to apply security to these objects using
+a fairly simple but powerful scheme of users and groups.
+
+It's also unique in that for most objects, you will not need to write any code.
+A fairly simple configuration file is all you need which you can then feed to
+SPOPS and have a class for your object ready to go, right out of thin air.
+
+The configuration you specify not only lists the properties of the object and
+possibly some information about where its data should be stored, but can also
+describe the relationship an object might have with another object (or
+objects).
+
+One great benefit is that you can retrofit SPOPS to existing data. If you
+don't use any of the metadata layers or security, you can simply describe your
+data in a configuration file, process the configuration and start making (and
+processing) objects. If you want to add security to these objects later, it's
+easy!
+
+WWW: http://search.cpan.org/search?dist=SPOPS
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-SPOPS/pkg-plist b/devel/p5-SPOPS/pkg-plist
new file mode 100644
index 000000000000..703fdd165f5f
--- /dev/null
+++ b/devel/p5-SPOPS/pkg-plist
@@ -0,0 +1,128 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SPOPS/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/ClassFactory.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/ClassFactory/DBI.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/ClassFactory/DefaultBehavior.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/ClassFactory/LDAP.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Configure.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Configure/DBI.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Configure/Ruleset.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/DBI.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/DBI/InterBase.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/DBI/MySQL.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/DBI/Oracle.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/DBI/Pg.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/DBI/SQLite.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/DBI/Sybase.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Error.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Exception.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Exception/DBI.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Exception/LDAP.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Exception/Security.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Export.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Export/DBI/Data.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Export/Object.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Export/Perl.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Export/SQL.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Export/XML.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/GDBM.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/HashFile.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Import.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Import/DBI/Data.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Import/DBI/Table.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Import/DBI/TableTransform.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Import/DBI/TableTransform/InterBase.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Import/DBI/TableTransform/MySQL.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Import/DBI/TableTransform/Oracle.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Import/DBI/TableTransform/Pg.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Import/DBI/TableTransform/SQLite.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Import/DBI/TableTransform/Sybase.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Import/Object.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Initialize.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Iterator.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Iterator/DBI.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Iterator/LDAP.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Iterator/WrapList.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Key/DBI/HandleField.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Key/DBI/Identity.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Key/DBI/Pool.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Key/DBI/Sequence.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Key/Random.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Key/UUID.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/LDAP.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/LDAP/MultiDatasource.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Loopback.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Manual.pod
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Manual/CodeGeneration.pod
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Manual/Configuration.pod
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Manual/Cookbook.pod
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Manual/Datasource.pod
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Manual/Exceptions.pod
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Manual/ImportExport.pod
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Manual/Intro.pod
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Manual/Object.pod
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Manual/ObjectRules.pod
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Manual/Relationships.pod
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Manual/Security.pod
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Manual/Serialization.pod
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/SQLInterface.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Secure.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Secure/Hierarchy.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Tie.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Tie/StrictField.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Tool/DBI/Datasource.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Tool/DBI/DiscoverField.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Tool/DBI/FindDefaults.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Tool/LDAP/Datasource.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Tool/ReadOnly.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Tool/UTFConvert.pm
+lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Utility.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/My/Common.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/My/Doodad.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/My/Group.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/My/LDAPConnect.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/My/Security.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/My/User.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/datasource_configure.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/datasource_configure_ldap.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/export_doodads.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/fetch_all.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/fetch_doodads.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/find_defaults_demo.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/ldap_multidatasource.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/stock_doodads.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/stock_user_group.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/users_groups_clear.sql
+%%PORTDOCS%%%%EXAMPLESDIR%%/users_groups_clear_interbase.sql
+%%PORTDOCS%%%%EXAMPLESDIR%%/users_groups_clear_oracle.sql
+%%PORTDOCS%%%%EXAMPLESDIR%%/users_groups_clear_pgsql.sql
+%%PORTDOCS%%%%EXAMPLESDIR%%/users_groups_interbase.sql
+%%PORTDOCS%%%%EXAMPLESDIR%%/users_groups_mysql.sql
+%%PORTDOCS%%%%EXAMPLESDIR%%/users_groups_oracle.sql
+%%PORTDOCS%%%%EXAMPLESDIR%%/users_groups_pgsql.sql
+%%PORTDOCS%%%%EXAMPLESDIR%%/users_groups_sqlite.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/users_groups_tsql.sql
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/My
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/ClassFactory
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Configure
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/DBI
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Exception
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Export/DBI
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Export
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Import/DBI/TableTransform
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Import/DBI
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Import
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Iterator
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Key/DBI
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Key
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/LDAP
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Manual
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Secure
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Tie
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Tool/DBI
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Tool/LDAP
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS/Tool
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SPOPS
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SPOPS