aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-SUPER
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-06-13 22:36:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-06-13 22:36:29 +0000
commit9d703df791d184049690696a982c546cc9b53f8a (patch)
tree4a1abf95ba5a4b013fa98c96489830a7f6fcfafc /devel/p5-SUPER
parentf7f1a576108aa3651f7b5222c928d1536daa7acd (diff)
downloadports-9d703df791d184049690696a982c546cc9b53f8a.tar.gz
ports-9d703df791d184049690696a982c546cc9b53f8a.zip
Notes
Diffstat (limited to 'devel/p5-SUPER')
-rw-r--r--devel/p5-SUPER/Makefile25
-rw-r--r--devel/p5-SUPER/distinfo3
-rw-r--r--devel/p5-SUPER/pkg-descr4
-rw-r--r--devel/p5-SUPER/pkg-plist3
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/p5-SUPER/Makefile b/devel/p5-SUPER/Makefile
new file mode 100644
index 000000000000..0741501b1c41
--- /dev/null
+++ b/devel/p5-SUPER/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-SUPER
+# Date created: 12 June, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SUPER
+PORTVERSION= 1.16
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Perl module control superclass method dispatch
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Sub-Identify>=0.04:${PORTSDIR}/devel/p5-Sub-Identify
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SUPER.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-SUPER/distinfo b/devel/p5-SUPER/distinfo
new file mode 100644
index 000000000000..242c22d502ac
--- /dev/null
+++ b/devel/p5-SUPER/distinfo
@@ -0,0 +1,3 @@
+MD5 (SUPER-1.16.tar.gz) = 3a0584598514f471f5df9480e12573c0
+SHA256 (SUPER-1.16.tar.gz) = a66e368694e5a38edf870fd8cd188c827171395ef98775b3bbed621a3feb5dba
+SIZE (SUPER-1.16.tar.gz) = 7749
diff --git a/devel/p5-SUPER/pkg-descr b/devel/p5-SUPER/pkg-descr
new file mode 100644
index 000000000000..c636ec2eba43
--- /dev/null
+++ b/devel/p5-SUPER/pkg-descr
@@ -0,0 +1,4 @@
+p5-SUPER is a perl module provides three different ways
+to control superclass method dispatch.
+
+WWW: http://search.cpan.org/dist/SUPER/
diff --git a/devel/p5-SUPER/pkg-plist b/devel/p5-SUPER/pkg-plist
new file mode 100644
index 000000000000..183f31d05131
--- /dev/null
+++ b/devel/p5-SUPER/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/SUPER.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SUPER/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SUPER