aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-SVN-Access
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-16 23:08:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-16 23:08:12 +0000
commit066ea086ac302801c0c81944e3d02efd39d5adae (patch)
tree045935c1ca5a6dd797602a83ee472e37d4c55542 /devel/p5-SVN-Access
parent2a873403de7008c58b673705f150c34acc980109 (diff)
downloadports-066ea086ac302801c0c81944e3d02efd39d5adae.tar.gz
ports-066ea086ac302801c0c81944e3d02efd39d5adae.zip
Notes
Diffstat (limited to 'devel/p5-SVN-Access')
-rw-r--r--devel/p5-SVN-Access/Makefile36
-rw-r--r--devel/p5-SVN-Access/distinfo3
-rw-r--r--devel/p5-SVN-Access/pkg-descr6
-rw-r--r--devel/p5-SVN-Access/pkg-plist10
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/p5-SVN-Access/Makefile b/devel/p5-SVN-Access/Makefile
new file mode 100644
index 000000000000..bca5d0184182
--- /dev/null
+++ b/devel/p5-SVN-Access/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-SVN-Access
+# Date created: 2008-02-11
+# Whom: Greg Larkin <glarkin@sourcehosting.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVN-Access
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SVN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@sourcehosting.net
+COMMENT= Perl extension to manipulate SVN Access files
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SVN/Base.pm:${PORTSDIR}/devel/subversion-perl \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SVN/Base.pm:${PORTSDIR}/devel/subversion-perl \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+
+PERL_CONFIGURE= yes
+
+MAN3= SVN::Access.3 \
+ SVN::Access::Group.3 \
+ SVN::Access::Resource.3
+
+post-install:
+ @cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
+ @${FIND} ${EXAMPLESDIR} -name \*.pl -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} 755
+ @${ECHO_CMD} '@exec ${FIND} ${EXAMPLESDIR} -name \*.pl -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} 755' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-SVN-Access/distinfo b/devel/p5-SVN-Access/distinfo
new file mode 100644
index 000000000000..0012380b8755
--- /dev/null
+++ b/devel/p5-SVN-Access/distinfo
@@ -0,0 +1,3 @@
+MD5 (SVN-Access-0.03.tar.gz) = 79fa39ea6792b4f246e38d5f3024ee69
+SHA256 (SVN-Access-0.03.tar.gz) = 7119364e9dc9b2319faf62781ba5e7293a232daae405ef30b7f3aaa2e9867105
+SIZE (SVN-Access-0.03.tar.gz) = 7247
diff --git a/devel/p5-SVN-Access/pkg-descr b/devel/p5-SVN-Access/pkg-descr
new file mode 100644
index 000000000000..e114b1f1d561
--- /dev/null
+++ b/devel/p5-SVN-Access/pkg-descr
@@ -0,0 +1,6 @@
+SVN::Access includes both an object oriented interface for manipulating
+SVN access files (AuthzSVNAccessFile files), as well as a command
+line interface to that object oriented programming interface
+(svnaclmgr.pl) which is in the examples/ directory.
+
+WWW: http://search.cpan.org/dist/SVN-Access/
diff --git a/devel/p5-SVN-Access/pkg-plist b/devel/p5-SVN-Access/pkg-plist
new file mode 100644
index 000000000000..d6387e362719
--- /dev/null
+++ b/devel/p5-SVN-Access/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/SVN/Access.pm
+%%SITE_PERL%%/SVN/Access/Group.pm
+%%SITE_PERL%%/SVN/Access/Resource.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/Access/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/Access
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN
+@dirrm %%SITE_PERL%%/SVN/Access
+@dirrmtry %%SITE_PERL%%/SVN
+%%EXAMPLESDIR%%/svnaclmgr.pl
+@dirrm %%EXAMPLESDIR%%