aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-SVN-Notify
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-03-03 13:57:31 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-03-03 13:57:31 +0000
commit8a2de6bda593d277c059fd2bc9efdb156e02535b (patch)
treee5c09cf74df427d8b374877e5dff61670d358166 /devel/p5-SVN-Notify
parentda9172ec2bde10bdd105a74a434f1af30ef8f143 (diff)
downloadports-8a2de6bda593d277c059fd2bc9efdb156e02535b.tar.gz
ports-8a2de6bda593d277c059fd2bc9efdb156e02535b.zip
Notes
Diffstat (limited to 'devel/p5-SVN-Notify')
-rw-r--r--devel/p5-SVN-Notify/Makefile27
-rw-r--r--devel/p5-SVN-Notify/distinfo2
-rw-r--r--devel/p5-SVN-Notify/pkg-descr9
-rw-r--r--devel/p5-SVN-Notify/pkg-plist7
4 files changed, 45 insertions, 0 deletions
diff --git a/devel/p5-SVN-Notify/Makefile b/devel/p5-SVN-Notify/Makefile
new file mode 100644
index 000000000000..7e497851282e
--- /dev/null
+++ b/devel/p5-SVN-Notify/Makefile
@@ -0,0 +1,27 @@
+# Ports collection Makefile for: SVN::Notify
+# Date created: 22 Feb 2005
+# Whom: dom@happygiraffe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVN-Notify
+PORTVERSION= 2.43
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/D/DW/DWHEELER/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dom@happygiraffe.net
+COMMENT= Subversion activity notification
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
+ ${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Coverage
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN1= svnnotify.1
+MAN3= SVN::Notify.3 SVN::Notify::HTML.3 SVN::Notify::HTML::ColorDiff.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-SVN-Notify/distinfo b/devel/p5-SVN-Notify/distinfo
new file mode 100644
index 000000000000..574d76a83fd9
--- /dev/null
+++ b/devel/p5-SVN-Notify/distinfo
@@ -0,0 +1,2 @@
+MD5 (SVN-Notify-2.43.tar.gz) = b4ae61a73ecf1bf1a50f5bc8dc03cf8e
+SIZE (SVN-Notify-2.43.tar.gz) = 35852
diff --git a/devel/p5-SVN-Notify/pkg-descr b/devel/p5-SVN-Notify/pkg-descr
new file mode 100644
index 000000000000..a14d215f553d
--- /dev/null
+++ b/devel/p5-SVN-Notify/pkg-descr
@@ -0,0 +1,9 @@
+This class may be used for sending email messages for Subversion repos-
+itory activity. There are a number of different modes supported, and
+SVN::Notify is fully subclassable, to easily add new functionality. By
+default, a list of all the files affected by the commit will be assem-
+bled and listed in a single message. An additional option allows diffs
+to be calculated for the changes and either appended to the message or
+added as an attachment.
+
+WWW: http://search.cpan.org/dist/SVN-Notify/
diff --git a/devel/p5-SVN-Notify/pkg-plist b/devel/p5-SVN-Notify/pkg-plist
new file mode 100644
index 000000000000..2e60804ecdd7
--- /dev/null
+++ b/devel/p5-SVN-Notify/pkg-plist
@@ -0,0 +1,7 @@
+bin/svnnotify
+%%SITE_PERL%%/SVN/Notify.pm
+%%SITE_PERL%%/SVN/Notify/HTML.pm
+%%SITE_PERL%%/SVN/Notify/HTML/ColorDiff.pm
+@unexec rmdir %D/%%SITE_PERL%%/SVN/Notify/HTML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/SVN/Notify 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/SVN 2>/dev/null || true