aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-SVN-Simple
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-03-16 16:54:34 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-03-16 16:54:34 +0000
commita8f5e9a818394ba446b8f19d0f8d797c0f571813 (patch)
tree1e7abd2c7353fdf1349b01d967be8b2d1baf4045 /devel/p5-SVN-Simple
parentb325fdc8117c9fc6434711b6e950d09df5cc61ab (diff)
downloadports-a8f5e9a818394ba446b8f19d0f8d797c0f571813.tar.gz
ports-a8f5e9a818394ba446b8f19d0f8d797c0f571813.zip
Notes
Diffstat (limited to 'devel/p5-SVN-Simple')
-rw-r--r--devel/p5-SVN-Simple/Makefile25
-rw-r--r--devel/p5-SVN-Simple/distinfo1
-rw-r--r--devel/p5-SVN-Simple/pkg-descr6
-rw-r--r--devel/p5-SVN-Simple/pkg-plist7
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/p5-SVN-Simple/Makefile b/devel/p5-SVN-Simple/Makefile
new file mode 100644
index 000000000000..a4b84171bc2b
--- /dev/null
+++ b/devel/p5-SVN-Simple/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-SVN-Simple
+# Date created: Mar 2004
+# Whom: Autrijus Tang <autrijus@autrijus.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVN-Simple
+PORTVERSION= 0.25
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/C/CL/CLKAO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= autrijus@autrijus.org
+COMMENT= Simple interface to SVN::Delta::Editor
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/subversion-perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SVN::Simple::Edit.3 SVN::Simple::Editor.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-SVN-Simple/distinfo b/devel/p5-SVN-Simple/distinfo
new file mode 100644
index 000000000000..1b30f251288c
--- /dev/null
+++ b/devel/p5-SVN-Simple/distinfo
@@ -0,0 +1 @@
+MD5 (SVN-Simple-0.25.tar.gz) = 559c41fa75797e2f33af1cead21897cf
diff --git a/devel/p5-SVN-Simple/pkg-descr b/devel/p5-SVN-Simple/pkg-descr
new file mode 100644
index 000000000000..93ea9c225529
--- /dev/null
+++ b/devel/p5-SVN-Simple/pkg-descr
@@ -0,0 +1,6 @@
+SVN::Simple::Edit wraps the subversion delta editor with a perl
+friendly interface and then you could easily drive it for describing
+changes to a tree.
+
+A common usage is to wrap the commit editor, so you could make commits
+to a subversion repository easily.
diff --git a/devel/p5-SVN-Simple/pkg-plist b/devel/p5-SVN-Simple/pkg-plist
new file mode 100644
index 000000000000..5736c01a62b5
--- /dev/null
+++ b/devel/p5-SVN-Simple/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/SVN/Simple/Edit.pm
+%%SITE_PERL%%/SVN/Simple/Editor.pm
+@dirrm %%SITE_PERL%%/SVN/Simple
+@unexec rmdir %D/%%SITE_PERL%%/SVN 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/Simple/Edit 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN 2>/dev/null || true